openSUSE-SU-2017:1885-1: important: Security update for xorg-x11-server

The following information has been provided by the opensuse security announce mailing list.

openSUSE Security Update: Security update for xorg-x11-server
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2017:1885-1
Rating:             important
References:         #1025084 #1035283
Cross-References:   CVE-2017-10971 CVE-2017-10972
Affected Products:
openSUSE Leap 42.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for xorg-x11-server fixes the following issues:

– CVE-2017-10971: Fix endianess handling of GenericEvent to prevent a
stack overflow by clients. (bnc#1035283)
– Make sure the type of all events to be sent by ProcXSendExtensionEvent
are in the allowed range.
– CVE-2017-10972: Initialize the xEvent eventT with zeros to avoid
information leakage.
– Improve retrieval of entropy for generating random authentication
cookies (boo#1025084)

Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

– openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-825=1

To bring your system up-to-date, use “zypper patch”.

Package List:

– openSUSE Leap 42.2 (i586 x86_64):

xorg-x11-server-7.6_1.18.3-12.20.1
xorg-x11-server-debuginfo-7.6_1.18.3-12.20.1
xorg-x11-server-debugsource-7.6_1.18.3-12.20.1
xorg-x11-server-extra-7.6_1.18.3-12.20.1
xorg-x11-server-extra-debuginfo-7.6_1.18.3-12.20.1
xorg-x11-server-sdk-7.6_1.18.3-12.20.1
xorg-x11-server-source-7.6_1.18.3-12.20.1

References:

https://www.suse.com/security/cve/CVE-2017-10971.html
https://www.suse.com/security/cve/CVE-2017-10972.html
https://bugzilla.suse.com/1025084
https://bugzilla.suse.com/1035283