SUSE-SU-2017:1865-1: important: Security update for cryptctl

The following information has been provided by the opensuse security announce mailing list.

SUSE Security Update: Security update for cryptctl
______________________________________________________________________________

Announcement ID:    SUSE-SU-2017:1865-1
Rating:             important
References:         #1041963
Cross-References:   CVE-2017-9270
Affected Products:
SUSE Linux Enterprise Server for SAP 12-SP2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for cryptctl fixes an issue that could have allowed a
malicious administrator to craft RPC requests to overwrite files outside
of key database. (bsc#1041963 / CVE-2017-9270)

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

– SUSE Linux Enterprise Server for SAP 12-SP2:

zypper in -t patch SUSE-SLE-SAP-12-SP2-2017-1158=1

To bring your system up-to-date, use “zypper patch”.

Package List:

– SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):

cryptctl-1.2.6-5.3.11
cryptctl-debuginfo-1.2.6-5.3.11
cryptctl-debugsource-1.2.6-5.3.11

References:

https://www.suse.com/security/cve/CVE-2017-9270.html
https://bugzilla.suse.com/1041963