[ GLSA 201711-04 ] MariaDB, MySQL: Root privilege escalation

\n\n–nextPart3121779.TDYWXWukaR
Content-Type: multipart/alternative; boundary=”nextPart1861973.LU5fRiVC4Z”
Content-Transfer-Encoding: 7Bit

This is a multi-part message in MIME format.

–nextPart1861973.LU5fRiVC4Z
Content-Transfer-Encoding: 7Bit
Content-Type: text/plain; charset=”us-ascii”

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Gentoo Linux Security Advisory GLSA 201711-04
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
https://security.gentoo.org/
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Severity: Normal
Title: MariaDB, MySQL: Root privilege escalation
Date: November 10, 2017
Bugs: #635704, #635706
ID: 201711-04

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Synopsis
========

A vulnerability was discovered in MariaDB and MySQL which may allow
local users to gain root privileges.

Background
==========

MySQL is a popular multi-threaded, multi-user SQL server. MariaDB is an
enhanced, drop-in replacement for MySQL.

Affected packages
=================

——————————————————————-
Package / Vulnerable / Unaffected
——————————————————————-
1 dev-db/mariadb = 10.0.30-r1
2 dev-db/mysql = 5.6.36-r1
——————————————————————-
2 affected packages

Description
===========

The Gentoo installation scripts before 2017-09-29 have chown calls for
user-writable directory trees, which allows local users to gain
privileges by leveraging access to the mysql account for creation of a
link.

Impact
======

A local attacker could escalate privileges to root.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MariaDB users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=dev-db/mariadb-10.0.30-r1”

All MySQL users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=dev-db/mysql-5.6.36-r1″

References
==========

[ 1 ] CVE-2017-15945
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15945

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201711-04

Concerns?
=========
–nextPart1861973.LU5fRiVC4Z
Content-Transfer-Encoding: 7Bit
Content-Type: text/html; charset=”us-ascii”

p, li { white-space: pre-wrap; }

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Gentoo Linux Security Advisory GLSA 201711-04

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

https://security.gentoo.org/

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

 

Severity: Normal

Title: MariaDB, MySQL: Root privilege escalation

Date: November 10, 2017

Bugs: #635704, #635706

ID: 201711-04

 

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

 

Synopsis

========

 

A vulnerability was discovered in MariaDB and MySQL which may allow

local users to gain root privileges.

 

Background

==========

 

MySQL is a popular multi-threaded, multi-user SQL server. MariaDB is an

enhanced, drop-in replacement for MySQL.

 

Affected packages

=================

 

——————————————————————-

Package / Vulnerable / Unaffected

——————————————————————-

1 dev-db/mariadb < 10.0.30-r1 >= 10.0.30-r1

2 dev-db/mysql < 5.6.36-r1 >= 5.6.36-r1

——————————————————————-

2 affected packages

 

Description

===========

 

The Gentoo installation scripts before 2017-09-29 have chown calls for

user-writable directory trees, which allows local users to gain

privileges by leveraging access to the mysql account for creation of a

link.

 

Impact

======

 

A local attacker could escalate privileges to root.

 

Workaround

==========

 

There is no known workaround at this time.

 

Resolution

==========

 

All MariaDB users should upgrade to the latest version:

 

# emerge –sync

# emerge –ask –oneshot –verbose ">=dev-db/mariadb-10.0.30-r1"

 

All MySQL users should upgrade to the latest version:

 

# emerge –sync

# emerge –ask –oneshot –verbose ">=dev-db/mysql-5.6.36-r1"

 

References

==========

 

[ 1 ] CVE-2017-15945

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15945

 

Availability

============

 

This GLSA and any updates to it are available for viewing at

the Gentoo Security Website:

 

https://security.gentoo.org/glsa/201711-04

 

Concerns?

=========

 

Security is a primary focus of Gentoo Linux and ensuring the

confidentiality and security of our users’ machines is of utmost

importance to us. Any security concerns should be addressed to

security@gentoo.org or alternatively, you may file a bug at

https://bugs.gentoo.org.

 

License

=======

 

Copyright 2017 Gentoo Foundation, Inc; referenced text

belongs to its owner(s).

 

The contents of this document are licensed under the

Creative Commons – Attribution / Share Alike license.

 

http://creativecommons.org/licenses/by-sa/2.5

–nextPart1861973.LU5fRiVC4Z–

–nextPart3121779.TDYWXWukaR
Content-Type: application/pgp-signature; name=”signature.asc”
Content-Description: This is a digitally signed message part.
Content-Transfer-Encoding: 7Bit

—–BEGIN PGP SIGNATURE—–

iQEzBAABCAAdFiEEiDRK3jyVBE/RkymqpRQw84X1dt0FAloGLIsACgkQpRQw84X1
dt33HggAlxOZMfZiMCfZeReK06nLaSlc0cigDNt2oZrcTBbDcQz++vCxE18Fmd9L
pKZRaeZTFwUhmAXjRxTGnWWVLwwv18r8MotJLc7lMURWP8DkmOSNCeIRcKS1rUY5
e5RHipFxeTYA9dWZ9lkKMp7mxVQWLC5cMceE1/MZWzA7b3lsy1KPYXVjMUNk9qHV
Oj2iR21o8AV9HXoOXE7sJ9r9yb34TVyMWj1et5OL/8FOsS0cgOhKal2MYi914ktg
hlL1fgnn9ItjfBTzZpqLFyFMchbDVQxC0iRfqgdSFktTQWYWaRh2gb4U6AdaUEbL
Ga9PEbPFk/5ZLpu9p0/wLzkL7IZNjA==
=UG/e
—–END PGP SIGNATURE—–

–nextPart3121779.TDYWXWukaR–