SUSE-SU-2017:3039-1: important: Security update for tomcat

\n\n SUSE Security Update: Security update for tomcat
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:3039-1
Rating: important
References: #1019016 #1042910 #1053352 #1059554 #977410

Cross-References: CVE-2017-12617 CVE-2017-5664 CVE-2017-7674

Affected Products:
SUSE Linux Enterprise Server for Raspberry Pi 12-SP2
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Server 12-SP2
______________________________________________________________________________

An update that solves three vulnerabilities and has two
fixes is now available.

Description:

This update for tomcat fixes the following issues:

Security issues fixed:

– CVE-2017-5664: A problem in handling error pages was fixed, to avoid
potential file overwrites during error page handling. (bsc#1042910).
– CVE-2017-7674: A CORS Filter issue could lead to client and server side
cache poisoning (bsc#1053352)
– CVE-2017-12617: A remote code execution possibility via JSP Upload was
fixed (bsc#1059554)

Non security bugs fixed:

– Fix tomcat-digest classpath error (bsc#977410)
– Fix packaged /etc/alternatives symlinks for api libs that caused rpm -V
to report link mismatch (bsc#1019016)

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

– SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:

zypper in -t patch SUSE-SLE-RPI-12-SP2-2017-1874=1

– SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2017-1874=1

– SUSE Linux Enterprise Server 12-SP2:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2017-1874=1

To bring your system up-to-date, use “zypper patch”.

Package List:

– SUSE Linux Enterprise Server for Raspberry Pi 12-SP2 (noarch):

tomcat-8.0.43-29.5.1
tomcat-admin-webapps-8.0.43-29.5.1
tomcat-docs-webapp-8.0.43-29.5.1
tomcat-el-3_0-api-8.0.43-29.5.1
tomcat-javadoc-8.0.43-29.5.1
tomcat-jsp-2_3-api-8.0.43-29.5.1
tomcat-lib-8.0.43-29.5.1
tomcat-servlet-3_1-api-8.0.43-29.5.1
tomcat-webapps-8.0.43-29.5.1

– SUSE Linux Enterprise Server 12-SP3 (noarch):

tomcat-8.0.43-29.5.1
tomcat-admin-webapps-8.0.43-29.5.1
tomcat-docs-webapp-8.0.43-29.5.1
tomcat-el-3_0-api-8.0.43-29.5.1
tomcat-javadoc-8.0.43-29.5.1
tomcat-jsp-2_3-api-8.0.43-29.5.1
tomcat-lib-8.0.43-29.5.1
tomcat-servlet-3_1-api-8.0.43-29.5.1
tomcat-webapps-8.0.43-29.5.1

– SUSE Linux Enterprise Server 12-SP2 (noarch):

tomcat-8.0.43-29.5.1
tomcat-admin-webapps-8.0.43-29.5.1
tomcat-docs-webapp-8.0.43-29.5.1
tomcat-el-3_0-api-8.0.43-29.5.1
tomcat-javadoc-8.0.43-29.5.1
tomcat-jsp-2_3-api-8.0.43-29.5.1
tomcat-lib-8.0.43-29.5.1
tomcat-servlet-3_1-api-8.0.43-29.5.1
tomcat-webapps-8.0.43-29.5.1

References:

https://www.suse.com/security/cve/CVE-2017-12617.html
https://www.suse.com/security/cve/CVE-2017-5664.html
https://www.suse.com/security/cve/CVE-2017-7674.html
https://bugzilla.suse.com/1019016
https://bugzilla.suse.com/1042910
https://bugzilla.suse.com/1053352
https://bugzilla.suse.com/1059554
https://bugzilla.suse.com/977410


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org