CVE-2018-5249

CVE: CVE-2018-5249
Published: 2018-01-05T20:29Z
Vendor: shaarli_project
Products: shaarli
Versions: 0.0.40, 0.0.41, 0.0.42, 0.0.43, 0.0.44, 0.0.45, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.7.0, 0.7.1, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.8.4, 0.9.0, 0.9.1, 0.9.2,
Description Language: en
Description: Cross-site scripting (XSS) vulnerability in Shaarli before 0.8.5 and 0.9.x before 0.9.3 allows remote attackers to inject arbitrary code via the login form’s username field (aka the login parameter to the ban_canLogin function in index.php).
References:
https://github.com/shaarli/Shaarli/pull/1046
https://github.com/shaarli/Shaarli/releases/tag/v0.8.5
https://github.com/shaarli/Shaarli/releases/tag/v0.9.3