CVE-2018-6406

CVE: CVE-2018-6406
Published: 2018-01-30T21:29Z
Vendor: webmproject
Products: libwebm
Versions: 2018-01-30,
Description Language: en
Description: The function ParseVP9SuperFrameIndex in common/libwebm_util.cc in libwebm through 2018-01-30 does not validate the child_frame_length data obtained from a .webm file, which allows remote attackers to cause an information leak or a denial of service (heap-based buffer over-read and later out-of-bounds write), or possibly have unspecified other impact.
References:
https://bugs.chromium.org/p/webm/issues/detail?id=1492
https://github.com/dwfault/PoCs/blob/master/libwebm%20ParseVP9SuperFrameIndex%20memory%20corruption/libwebm%20ParseVP9SuperFrameIndex%20OOB%20read.md