[ GLSA 201801-01 ] Binutils: Multiple vulnerabilities

\n\n–nextPart2916297.g4bqzPvn4H
Content-Type: multipart/alternative; boundary=”nextPart2169445.10PCYapmO2″
Content-Transfer-Encoding: 7Bit

This is a multi-part message in MIME format.

–nextPart2169445.10PCYapmO2
Content-Transfer-Encoding: 7Bit
Content-Type: text/plain; charset=”us-ascii”

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Gentoo Linux Security Advisory GLSA 201801-01
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
https://security.gentoo.org/
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Severity: Normal
Title: Binutils: Multiple vulnerabilities
Date: January 07, 2018
Bugs: #624700, #627516, #628538, #629344, #629922, #631324,
#632100, #632132, #632384, #632668, #633988, #635218,
#635692, #635860, #635968
ID: 201801-01

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Synopsis
========

Multiple vulnerabilities have been found in Binutils, the worst of
which may allow remote attackers to cause a Denial of Service
condition.

Background
==========

The GNU Binutils are a collection of tools to create, modify and
analyse binary files. Many of the files use BFD, the Binary File
Descriptor library, to do low-level manipulation.

Affected packages
=================

——————————————————————-
Package / Vulnerable / Unaffected
——————————————————————-
1 sys-devel/binutils = 2.29.1-r1

Description
===========

Multiple vulnerabilities have been discovered in Binutils. Please
review the referenced CVE identifiers for details.

Impact
======

A remote attacker, by enticing a user to compile/execute a specially
crafted ELF, tekhex, PE, or binary file, could possibly cause a Denial
of Service condition.

Workaround
==========

There are no known workarounds at this time.

Resolution
==========

All Binutils users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=sys-devel/binutils-2.29.1-r1″

References
==========

[ 1 ] CVE-2017-12456
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12456
[ 2 ] CVE-2017-12799
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12799
[ 3 ] CVE-2017-12967
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12967
[ 4 ] CVE-2017-14128
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14128
[ 5 ] CVE-2017-14129
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14129
[ 6 ] CVE-2017-14130
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14130
[ 7 ] CVE-2017-14333
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14333
[ 8 ] CVE-2017-15023
https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15023
[ 9 ] CVE-2017-15938
–nextPart2169445.10PCYapmO2
Content-Transfer-Encoding: 7Bit
Content-Type: text/html; charset=”us-ascii”

p, li { white-space: pre-wrap; }

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Gentoo Linux Security Advisory GLSA 201801-01

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

https://security.gentoo.org/

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

 

Severity: Normal

Title: Binutils: Multiple vulnerabilities

Date: January 07, 2018

Bugs: #624700, #627516, #628538, #629344, #629922, #631324,

#632100, #632132, #632384, #632668, #633988, #635218,

#635692, #635860, #635968

ID: 201801-01

 

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

 

Synopsis

========

 

Multiple vulnerabilities have been found in Binutils, the worst of

which may allow remote attackers to cause a Denial of Service

condition.

 

Background

==========

 

The GNU Binutils are a collection of tools to create, modify and

analyse binary files. Many of the files use BFD, the Binary File

Descriptor library, to do low-level manipulation.

 

Affected packages

=================

 

——————————————————————-

Package / Vulnerable / Unaffected

——————————————————————-

1 sys-devel/binutils < 2.29.1-r1 >= 2.29.1-r1

 

Description

===========

 

Multiple vulnerabilities have been discovered in Binutils. Please

review the referenced CVE identifiers for details.

 

Impact

======

 

A remote attacker, by enticing a user to compile/execute a specially

crafted ELF, tekhex, PE, or binary file, could possibly cause a Denial

of Service condition.

 

Workaround

==========

 

There are no known workarounds at this time.

 

Resolution

==========

 

All Binutils users should upgrade to the latest version:

 

# emerge –sync

# emerge –ask –oneshot –verbose ">=sys-devel/binutils-2.29.1-r1"

 

References

==========

 

[ 1 ] CVE-2017-12456

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12456

[ 2 ] CVE-2017-12799

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12799

[ 3 ] CVE-2017-12967

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-12967

[ 4 ] CVE-2017-14128

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14128

[ 5 ] CVE-2017-14129

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14129

[ 6 ] CVE-2017-14130

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14130

[ 7 ] CVE-2017-14333

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-14333

[ 8 ] CVE-2017-15023

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15023

[ 9 ] CVE-2017-15938

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15938

[ 10 ] CVE-2017-15939

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15939

[ 11 ] CVE-2017-15996

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-15996

[ 12 ] CVE-2017-7209

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7209

[ 13 ] CVE-2017-7210

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7210

[ 14 ] CVE-2017-7223

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7223

[ 15 ] CVE-2017-7224

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7224

[ 16 ] CVE-2017-7225

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7225

[ 17 ] CVE-2017-7227

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-7227

[ 18 ] CVE-2017-9743

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9743

[ 19 ] CVE-2017-9746

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9746

[ 20 ] CVE-2017-9749

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9749

[ 21 ] CVE-2017-9750

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9750

[ 22 ] CVE-2017-9751

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9751

[ 23 ] CVE-2017-9755

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9755

[ 24 ] CVE-2017-9756

https://nvd.nist.gov/nvd.cfm?cvename=CVE-2017-9756

 

Availability

============

 

This GLSA and any updates to it are available for viewing at

the Gentoo Security Website:

 

https://security.gentoo.org/glsa/201801-01

 

Concerns?

=========

 

Security is a primary focus of Gentoo Linux and ensuring the

confidentiality and security of our users’ machines is of utmost

importance to us. Any security concerns should be addressed to

security@gentoo.org or alternatively, you may file a bug at

https://bugs.gentoo.org.

 

License

=======

 

Copyright 2018 Gentoo Foundation, Inc; referenced text

belongs to its owner(s).

 

The contents of this document are licensed under the

Creative Commons – Attribution / Share Alike license.

 

http://creativecommons.org/licenses/by-sa/2.5

–nextPart2169445.10PCYapmO2–

–nextPart2916297.g4bqzPvn4H
Content-Type: application/pgp-signature; name=”signature.asc”
Content-Description: This is a digitally signed message part.
Content-Transfer-Encoding: 7Bit

—–BEGIN PGP SIGNATURE—–

iQEzBAABCAAdFiEEiDRK3jyVBE/RkymqpRQw84X1dt0FAlpSqNUACgkQpRQw84X1
dt08Gwf/QFkJVuwlBaED7msBju0E2rQECKnO7Vl35NIZ9ZjoS0kHRrCAMpCYGF2P
0SRqD/GukoVDuvpDAYqg5MrdK4jHJhBPnNvzaggbT0v3jFnDtFwLEIFjOBT158SG
fdkQQPWVazxydSyvaTQp/bvAbkihXlwkRSI8VJ67yKVAmBakU0FhbawhHVUshBAv
ooQ3yZt9XxpT2/Q+c1I8zplBXZrAVq0T4XDgCK+VYnq86/IZUXzPb6CNochesz4V
UiMk+YGpKQNAQDvfjUa3lpcJkyFiQHdawBP2FhNFkXNL8x2yqHHxNi38mZRrO9h/
9ASqr2C9ntPJc88D728+B3A3UcrHVA==
=5hai
—–END PGP SIGNATURE—–

–nextPart2916297.g4bqzPvn4H–