[ GLSA 201801-14 ] Xen: Multiple vulnerabilities

\n\nThis is an OpenPGP/MIME signed message (RFC 4880 and 3156)
–ZDhvqKRAD0vT4Zhm8oj3CYSLTtxA7kwkl
Content-Type: multipart/mixed; boundary=”nwpu3OcjJZCuiX4bxjeYPaXNqDz2mYZD0″;
protected-headers=”v1″
From: Thomas Deutschmann
Reply-To: security@gentoo.org
To: gentoo-announce@lists.gentoo.org
Message-ID:
Subject: [ GLSA 201801-14 ] Xen: Multiple vulnerabilities

–nwpu3OcjJZCuiX4bxjeYPaXNqDz2mYZD0
Content-Type: text/plain; charset=utf-8
Content-Language: en-US
Content-Transfer-Encoding: quoted-printable

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Gentoo Linux Security Advisory GLSA 201801-14
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
https://security.gentoo.org/
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Severity: High
Title: Xen: Multiple vulnerabilities
Date: January 14, 2018
Bugs: #627962, #634668, #637540, #637542, #639688, #641566
ID: 201801-14

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Synopsis
=3D=3D=3D=3D=3D=3D=3D=3D

Multiple vulnerabilities have been found in Xen, the worst of which
could allow for privilege escalation.

Background
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Xen is a bare-metal hypervisor.

Affected packages
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

——————————————————————-
Package / Vulnerable / Unaffected
——————————————————————-
1 app-emulation/xen =3D 4.9.1-r1
2 app-emulation/xen-tools =3D 4.9.1-r1
——————————————————————-
2 affected packages

Description
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

Multiple vulnerabilities have been discovered in Xen. Please review the
referenced CVE identifiers for details.

Impact
=3D=3D=3D=3D=3D=3D

A local attacker could potentially execute arbitrary code with the
privileges of the Xen (QEMU) process on the host, gain privileges on
the host system, or cause a Denial of Service condition.

Workaround
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

There is no known workaround at this time.

Resolution
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

All Xen users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=3Dapp-emulation/xen-4.9.1-r1”

All Xen tools users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot -v “>=3Dapp-emulation/xen-tools-4.9.1-r1″

References
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

[ 1 ] CVE-2017-12134
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-12134
[ 2 ] CVE-2017-12135
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-12135
[ 3 ] CVE-2017-12136
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-12136
[ 4 ] CVE-2017-12137
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-12137
[ 5 ] CVE-2017-15588
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15588
[ 6 ] CVE-2017-15589
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15589
[ 7 ] CVE-2017-15590
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15590
[ 8 ] CVE-2017-15591
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15591
[ 9 ] CVE-2017-15592
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15592
[ 10 ] CVE-2017-15593
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15593
[ 11 ] CVE-2017-15594
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15594
[ 12 ] CVE-2017-15595
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-15595
[ 13 ] CVE-2017-17044
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-17044
[ 14 ] CVE-2017-17045
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-17045
[ 15 ] CVE-2017-17046
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-17046
[ 16 ] CVE-2017-17563
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-17563
[ 17 ] CVE-2017-17564
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-17564
[ 18 ] CVE-2017-17565
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-17565
[ 19 ] CVE-2017-17566
https://nvd.nist.gov/nvd.cfm?cvename=3DCVE-2017-17566

Availability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/201801-14

Concerns?
=3D=3D=3D=3D=3D=3D=3D=3D=3D

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users’ machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=3D=3D=3D=3D=3D=3D=3D

Copyright 2018 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons – Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

–nwpu3OcjJZCuiX4bxjeYPaXNqDz2mYZD0–

–ZDhvqKRAD0vT4Zhm8oj3CYSLTtxA7kwkl
Content-Type: application/pgp-signature; name=”signature.asc”
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename=”signature.asc”

—–BEGIN PGP SIGNATURE—–
Version: GnuPG v2

iQKTBAEBCgB9FiEEM8WEgsQCKS0uPFwGlwn5DDyW/8gFAlpb7EJfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDMz
QzU4NDgyQzQwMjI5MkQyRTNDNUMwNjk3MDlGOTBDM0M5NkZGQzgACgkQlwn5DDyW
/8iq3Q//d55ZWQDUVXuvBOgBIEPwGAOF0xJkY4Y3IQuR3rdX4CdU4cE6lQU1gxuj
lF4dL626pI5oY9qxFHMsNSUI8hUu6211KDdJf6VF4368yL00bLA1xzLUei0BVW1i
//T5N4vMniqoGVzeRlVExFgSV1xiQcFz7cdzn0YBjs4qXd8VlNMREJ7nok7HnnGK
2HKwFev2AIgebjGh1ECjLMAtDCvZ557MfQlyHIorYDVDxlmJaeAoxtEjELKbNO8S
85tsvhNC9QFXwY5xYdb6BKiCx3qq92mDac/QUHdty0xxxMjH3JT2ozW+zxqQxMoq
7semSidzHQzvMvR2q5+NJD6vgSANQCq+e8wGdbmqMKK+ZnAD0P0bqk/maPUqpL3d
aIwqHrJpbcrYIi/LeG10ODVfgFtK3BmooM21u6R6JpkzjvvFfcUxLMGez/INNhGP
/cx4KryjgHmOK1lcVwvQIFS+B1gZ/cBPmSKCjYEKIGgQmHsuwi87S8b45P5rSJ3g
jvXn3zGkI12zoh4KVDBeV0SfFvPIX227/rlt/oKy0RmclnH3dEDo8kKKUDSVrj/9
fbapPSsDzyDEohtyjT5kX8/esjYlJh5tAdkjgQHyGpCpt3hbgzgVkQKOEtY+DRhy
ZqQ53GaenzOSOE65CTpqSJqgQZJJ2R1zOPfqb4LCx0VkDZteFS8=
=XYeU
—–END PGP SIGNATURE—–

–ZDhvqKRAD0vT4Zhm8oj3CYSLTtxA7kwkl–