CVE-2018-1000025

CVE: CVE-2018-1000025
Published: 2018-02-09T23:29Z
Description Language: en
Description: Jerome Gamez Firebase Admin SDK for PHP version from 3.2.0 to 3.8.0 contains a Incorrect Access Control vulnerability in src/Firebase/Auth/IdTokenVerifier.php does not verify for token signature that can result in JWT with any email address and user ID could be forged from an actual token, or from thin air. This attack appear to be exploitable via Attacker would only need to know email address of the victim on most cases.. This vulnerability appears to have been fixed in 3.8.1.
References:
https://github.com/kreait/firebase-php/pull/151
https://github.com/kreait/firebase-php/releases/tag/3.8.1