CVE-2018-1000058

CVE: CVE-2018-1000058
Published: 2018-02-09T23:29Z
Vendor: jenkins
Products: pipeline_supporting_apis
Versions: 2.17,
Description Language: en
Description: Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.
References:
http://www.securityfocus.com/bid/103034
https://jenkins.io/security/advisory/2018-02-05/