CVE-2018-7715

CVE: CVE-2018-7715
Published: 2018-03-05T23:29Z
Description Language: en
Description: PrivateVPN 2.0.31 for macOS suffers from a root privilege escalation vulnerability with its com.privat.vpn.helper privileged helper tool. This privileged helper tool implements an XPC service that allows arbitrary installed applications to connect and send messages. The XPC service extracts the path string from the corresponding XPC message. This string is supposed to point to PrivateVPN’s internal openvpn binary. If a new connection has not already been established, an attacker can send the XPC service a malicious XPC message with the path string pointing at a binary that he or she controls. This results in the execution of arbitrary code as the root user.
References:
https://github.com/VerSprite/research/blob/master/advisories/VS-2018-005.md