SUSE-SU-2018:1047-1: important: Security update for PackageKit


SUSE Security Update: Security update for PackageKit
______________________________________________________________________________

Announcement ID: SUSE-SU-2018:1047-1
Rating: important
References: #1086936
Cross-References: CVE-2018-1106
Affected Products:
SUSE Linux Enterprise Workstation Extension 12-SP3
SUSE Linux Enterprise Software Development Kit 12-SP3
SUSE Linux Enterprise Server 12-SP3
SUSE Linux Enterprise Desktop 12-SP3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

– CVE-2018-1106: Drop the polkit rule which could allow users in wheel
group to install packages without root password (bsc#1086936).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– SUSE Linux Enterprise Workstation Extension 12-SP3:

zypper in -t patch SUSE-SLE-WE-12-SP3-2018-719=1

– SUSE Linux Enterprise Software Development Kit 12-SP3:

zypper in -t patch SUSE-SLE-SDK-12-SP3-2018-719=1

– SUSE Linux Enterprise Server 12-SP3:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2018-719=1

– SUSE Linux Enterprise Desktop 12-SP3:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP3-2018-719=1

Package List:

– SUSE Linux Enterprise Workstation Extension 12-SP3 (x86_64):

PackageKit-debuginfo-1.1.3-24.6.1
PackageKit-debugsource-1.1.3-24.6.1
PackageKit-gstreamer-plugin-1.1.3-24.6.1
PackageKit-gstreamer-plugin-debuginfo-1.1.3-24.6.1
PackageKit-gtk3-module-1.1.3-24.6.1
PackageKit-gtk3-module-debuginfo-1.1.3-24.6.1

– SUSE Linux Enterprise Software Development Kit 12-SP3 (aarch64 ppc64le s390x x86_64):

PackageKit-debuginfo-1.1.3-24.6.1
PackageKit-debugsource-1.1.3-24.6.1
PackageKit-devel-1.1.3-24.6.1
PackageKit-devel-debuginfo-1.1.3-24.6.1
libpackagekit-glib2-devel-1.1.3-24.6.1

– SUSE Linux Enterprise Server 12-SP3 (aarch64 ppc64le s390x x86_64):

PackageKit-1.1.3-24.6.1
PackageKit-backend-zypp-1.1.3-24.6.1
PackageKit-backend-zypp-debuginfo-1.1.3-24.6.1
PackageKit-debuginfo-1.1.3-24.6.1
PackageKit-debugsource-1.1.3-24.6.1
libpackagekit-glib2-18-1.1.3-24.6.1
libpackagekit-glib2-18-debuginfo-1.1.3-24.6.1
typelib-1_0-PackageKitGlib-1_0-1.1.3-24.6.1

– SUSE Linux Enterprise Server 12-SP3 (noarch):

PackageKit-lang-1.1.3-24.6.1

– SUSE Linux Enterprise Desktop 12-SP3 (noarch):

PackageKit-lang-1.1.3-24.6.1

– SUSE Linux Enterprise Desktop 12-SP3 (x86_64):

PackageKit-1.1.3-24.6.1
PackageKit-backend-zypp-1.1.3-24.6.1
PackageKit-backend-zypp-debuginfo-1.1.3-24.6.1
PackageKit-debuginfo-1.1.3-24.6.1
PackageKit-debugsource-1.1.3-24.6.1
PackageKit-gstreamer-plugin-1.1.3-24.6.1
PackageKit-gstreamer-plugin-debuginfo-1.1.3-24.6.1
PackageKit-gtk3-module-1.1.3-24.6.1
PackageKit-gtk3-module-debuginfo-1.1.3-24.6.1
libpackagekit-glib2-18-1.1.3-24.6.1
libpackagekit-glib2-18-debuginfo-1.1.3-24.6.1
typelib-1_0-PackageKitGlib-1_0-1.1.3-24.6.1

References:

https://www.suse.com/security/cve/CVE-2018-1106.html
https://bugzilla.suse.com/1086936


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org