openSUSE-SU-2018:1275-1: important: Security update for Chromium


openSUSE Security Update: Security update for Chromium
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1275-1
Rating: important
References: #1092272 #1092923
Cross-References: CVE-2018-6120 CVE-2018-6121 CVE-2018-6122

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for Chromium to version 66.0.3359.170 fixes the following
issues:

Security issues fixed (boo#1092923):

– CVE-2018-6121: Privilege Escalation in extensions
– CVE-2018-6122: Type confusion in V8
– CVE-2018-6120: Heap buffer overflow in PDFium
– Various fixes from internal audits, fuzzing and other initiatives

The following bugs are fixed:
– boo#1092272: Improved support for subpixel rending

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-456=1

Package List:

– openSUSE Leap 42.3 (x86_64):

chromedriver-66.0.3359.170-158.1
chromedriver-debuginfo-66.0.3359.170-158.1
chromium-66.0.3359.170-158.1
chromium-debuginfo-66.0.3359.170-158.1
chromium-debugsource-66.0.3359.170-158.1

References:

https://www.suse.com/security/cve/CVE-2018-6120.html
https://www.suse.com/security/cve/CVE-2018-6121.html
https://www.suse.com/security/cve/CVE-2018-6122.html
https://bugzilla.suse.com/1092272
https://bugzilla.suse.com/1092923


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org