openSUSE-SU-2018:1440-1: Security update for jasper


openSUSE Security Update: Security update for jasper
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1440-1
Rating: low
References: #1087020
Cross-References: CVE-2018-9055
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for jasper fixes the following issues:

– CVE-2018-9055: denial of service via a reachable assertion in the
function jpc_firstone in libjasper/jpc/jpc_math.c could lead to
denial of service. (bsc#1087020)

This update was imported from the SUSE:SLE-12:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-531=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

jasper-1.900.14-182.1
jasper-debuginfo-1.900.14-182.1
jasper-debugsource-1.900.14-182.1
libjasper-devel-1.900.14-182.1
libjasper1-1.900.14-182.1
libjasper1-debuginfo-1.900.14-182.1

– openSUSE Leap 42.3 (x86_64):

libjasper1-32bit-1.900.14-182.1
libjasper1-debuginfo-32bit-1.900.14-182.1

References:

https://www.suse.com/security/cve/CVE-2018-9055.html
https://bugzilla.suse.com/1087020


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org