openSUSE-SU-2018:1596-1: important: Security update for xdg-utils


openSUSE Security Update: Security update for xdg-utils
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1596-1
Rating: important
References: #1093086
Cross-References: CVE-2017-18266
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for xdg-utils fixes this security issues:

– CVE-2017-18266: The open_envvar function in xdg-open did not validate
strings launching the program specified by the BROWSER environment
variable, which might allowed remote attackers to conduct
argument-injection attacks via a crafted URL (bsc#1093086).

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-573=1

Package List:

– openSUSE Leap 15.0 (noarch):

xdg-utils-20170508-lp150.3.3.2

References:

https://www.suse.com/security/cve/CVE-2017-18266.html
https://bugzilla.suse.com/1093086


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org