openSUSE-SU-2018:1600-1: important: Security update for glibc


openSUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1600-1
Rating: important
References: #1086690 #1094150 #1094154 #1094161
Cross-References: CVE-2017-18269 CVE-2018-11236 CVE-2018-11237

Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:

This update for glibc fixes the following issues:

– CVE-2017-18269: Fix SSE2 memmove issue when crossing 2GB boundary
(bsc#1094150)
– CVE-2018-11236: Fix overflow in path length computation (bsc#1094161)
– CVE-2018-11237: Don’t write beyond buffer destination in
__mempcpy_avx512_no_vzeroupper (bsc#1094154)

Non security bugs fixed:

– Fix crash in resolver on memory allocation failure (bsc#1086690)

This update was imported from the SUSE:SLE-12-SP2:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-567=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

glibc-2.22-19.1
glibc-debuginfo-2.22-19.1
glibc-debugsource-2.22-19.1
glibc-devel-2.22-19.1
glibc-devel-debuginfo-2.22-19.1
glibc-devel-static-2.22-19.1
glibc-extra-2.22-19.1
glibc-extra-debuginfo-2.22-19.1
glibc-locale-2.22-19.1
glibc-locale-debuginfo-2.22-19.1
glibc-profile-2.22-19.1
glibc-utils-2.22-19.1
glibc-utils-debuginfo-2.22-19.1
glibc-utils-debugsource-2.22-19.1
nscd-2.22-19.1
nscd-debuginfo-2.22-19.1

– openSUSE Leap 42.3 (noarch):

glibc-html-2.22-19.1
glibc-i18ndata-2.22-19.1
glibc-info-2.22-19.1

– openSUSE Leap 42.3 (x86_64):

glibc-32bit-2.22-19.2
glibc-debuginfo-32bit-2.22-19.2
glibc-devel-32bit-2.22-19.2
glibc-devel-debuginfo-32bit-2.22-19.2
glibc-devel-static-32bit-2.22-19.2
glibc-locale-32bit-2.22-19.2
glibc-locale-debuginfo-32bit-2.22-19.2
glibc-profile-32bit-2.22-19.2
glibc-utils-32bit-2.22-19.1
glibc-utils-debuginfo-32bit-2.22-19.1

– openSUSE Leap 42.3 (i586):

glibc-obsolete-2.22-19.1
glibc-obsolete-debuginfo-2.22-19.1

– openSUSE Leap 42.3 (i686):

glibc-2.22-19.2
glibc-debuginfo-2.22-19.2
glibc-debugsource-2.22-19.2
glibc-devel-2.22-19.2
glibc-devel-debuginfo-2.22-19.2
glibc-devel-static-2.22-19.2
glibc-locale-2.22-19.2
glibc-locale-debuginfo-2.22-19.2
glibc-profile-2.22-19.2

References:

https://www.suse.com/security/cve/CVE-2017-18269.html
https://www.suse.com/security/cve/CVE-2018-11236.html
https://www.suse.com/security/cve/CVE-2018-11237.html
https://bugzilla.suse.com/1086690
https://bugzilla.suse.com/1094150
https://bugzilla.suse.com/1094154
https://bugzilla.suse.com/1094161


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org