openSUSE-SU-2018:1708-1: moderate: Security update for enigmail


openSUSE Security Update: Security update for enigmail
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1708-1
Rating: moderate
References: #1096745 #1097525
Cross-References: CVE-2018-12019 CVE-2018-12020
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for enigmail fixes vulnerabilities that allowed spoofing of
e-mail signatures:

– CVE-2018-12019: signature spoofing via specially crafted OpenPGP user
IDs (boo#1097525)
– CVE-2018-12020: signature spoofing via diagnostic output of the original
file name in GnuPG verbose mode (boo#1096745) This mitigation prevents
CVE-2018-12020 from being exploited even if GnuPG is not patched.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-630=1

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-630=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

enigmail-2.0.7-21.1

– openSUSE Leap 15.0 (x86_64):

enigmail-2.0.7-lp150.2.12.1

References:

https://www.suse.com/security/cve/CVE-2018-12019.html
https://www.suse.com/security/cve/CVE-2018-12020.html
https://bugzilla.suse.com/1096745
https://bugzilla.suse.com/1097525


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org