openSUSE-SU-2018:1724-1: important: Security update for gpg2


openSUSE Security Update: Security update for gpg2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1724-1
Rating: important
References: #1096745
Cross-References: CVE-2018-12020
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gpg2 fixes the following security issue:

– CVE-2018-12020: GnuPG mishandled the original filename during decryption
and verification actions, which allowed remote attackers to spoof the
output that GnuPG sends on file descriptor 2 to other programs that use
the “–status-fd 2”
option (bsc#1096745)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-640=1

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-640=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

gpg2-2.0.24-9.3.1
gpg2-debuginfo-2.0.24-9.3.1
gpg2-debugsource-2.0.24-9.3.1

– openSUSE Leap 42.3 (noarch):

gpg2-lang-2.0.24-9.3.1

– openSUSE Leap 15.0 (i586 x86_64):

gpg2-2.2.5-lp150.3.3.1
gpg2-debuginfo-2.2.5-lp150.3.3.1
gpg2-debugsource-2.2.5-lp150.3.3.1

– openSUSE Leap 15.0 (noarch):

gpg2-lang-2.2.5-lp150.3.3.1

References:

https://www.suse.com/security/cve/CVE-2018-12020.html
https://bugzilla.suse.com/1096745


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org