openSUSE-SU-2018:1767-1: moderate: Security update for matrix-synapse


openSUSE Security Update: Security update for matrix-synapse
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1767-1
Rating: moderate
References: #1096833
Cross-References: CVE-2018-12291
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for matrix-synapse fixes the following security issue:

– CVE-2018-12291: visibility rules were not applied correctly in the
get_missing_events federation API (boo#1096833)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-654=1

Package List:

– openSUSE Leap 15.0 (noarch):

python2-matrix-synapse-0.28.1-lp150.2.4.1
python3-matrix-synapse-0.28.1-lp150.2.4.1

References:

https://www.suse.com/security/cve/CVE-2018-12291.html
https://bugzilla.suse.com/1096833


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org