openSUSE-SU-2018:1811-1: moderate: Security update for go1.9


openSUSE Security Update: Security update for go1.9
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1811-1
Rating: moderate
References: #1081495
Cross-References: CVE-2018-7187
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for go1.9 fixes the following issues:

Security issues fixed:

– CVE-2018-7187: arbitrary command execution via VCS path (boo#1081495)

Non-security changes:

– Update to version 1.9.7
– fixes to the go command and compiler
– minimal support to the go command for the vgo transition

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-672=1

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-672=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

go-1.9.7-37.2
go-doc-1.9.7-37.2
go1.9-1.9.7-10.1
go1.9-doc-1.9.7-10.1

– openSUSE Leap 42.3 (x86_64):

go-race-1.9.7-37.2
go1.9-race-1.9.7-10.1

– openSUSE Leap 15.0 (i586 x86_64):

go-1.9.7-lp150.2.4.1
go-doc-1.9.7-lp150.2.4.1
go1.9-1.9.7-lp150.2.4.2
go1.9-doc-1.9.7-lp150.2.4.2

– openSUSE Leap 15.0 (x86_64):

go-race-1.9.7-lp150.2.4.1
go1.9-race-1.9.7-lp150.2.4.2

References:

https://www.suse.com/security/cve/CVE-2018-7187.html
https://bugzilla.suse.com/1081495


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org