openSUSE-SU-2018:1845-1: moderate: Security update for unixODBC


openSUSE Security Update: Security update for unixODBC
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1845-1
Rating: moderate
References: #1044970 #1082060 #1082290 #1082484
Cross-References: CVE-2018-7409 CVE-2018-7485
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves two vulnerabilities and has two fixes
is now available.

Description:

This update for unixODBC to version 2.3.6 fixes the following issues:

– CVE-2018-7409: Buffer overflow in unicode_to_ansi_copy() was fixed in
2.3.5 (bsc#1082290)
– CVE-2018-7485: Swapped arguments in SQLWriteFileDSN() in
odbcinst/SQLWriteFileDSN.c (bsc#1082484)

Other fixes:

– Enabled –enable-fastvalidate option in configure (bsc#1044970)

This update was imported from the SUSE:SLE-12-SP2:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-684=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

unixODBC-2.3.6-8.1
unixODBC-debuginfo-2.3.6-8.1
unixODBC-debugsource-2.3.6-8.1
unixODBC-devel-2.3.6-8.1

– openSUSE Leap 42.3 (x86_64):

unixODBC-32bit-2.3.6-8.1
unixODBC-debuginfo-32bit-2.3.6-8.1

References:

https://www.suse.com/security/cve/CVE-2018-7409.html
https://www.suse.com/security/cve/CVE-2018-7485.html
https://bugzilla.suse.com/1044970
https://bugzilla.suse.com/1082060
https://bugzilla.suse.com/1082290
https://bugzilla.suse.com/1082484


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org