openSUSE-SU-2018:1906-1: moderate: Security update for openssl


openSUSE Security Update: Security update for openssl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1906-1
Rating: moderate
References: #1097158 #1097624 #1098592
Cross-References: CVE-2018-0732
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for openssl fixes the following issues:

– CVE-2018-0732: During key agreement in a TLS handshake using a DH(E)
based ciphersuite a malicious server could have sent a very large prime
value to the client. This caused the client to spend an unreasonably
long period of time generating a key for this prime resulting in a hang
until the client has finished. This could be exploited in a Denial Of
Service attack (bsc#1097158).
– Blinding enhancements for ECDSA and DSA (bsc#1097624, bsc#1098592)

This update was imported from the SUSE:SLE-12-SP2:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-704=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

libopenssl-devel-1.0.2j-25.1
libopenssl1_0_0-1.0.2j-25.1
libopenssl1_0_0-debuginfo-1.0.2j-25.1
libopenssl1_0_0-hmac-1.0.2j-25.1
openssl-1.0.2j-25.1
openssl-cavs-1.0.2j-25.1
openssl-cavs-debuginfo-1.0.2j-25.1
openssl-debuginfo-1.0.2j-25.1
openssl-debugsource-1.0.2j-25.1

– openSUSE Leap 42.3 (noarch):

openssl-doc-1.0.2j-25.1

– openSUSE Leap 42.3 (x86_64):

libopenssl-devel-32bit-1.0.2j-25.1
libopenssl1_0_0-32bit-1.0.2j-25.1
libopenssl1_0_0-debuginfo-32bit-1.0.2j-25.1
libopenssl1_0_0-hmac-32bit-1.0.2j-25.1

References:

https://www.suse.com/security/cve/CVE-2018-0732.html
https://bugzilla.suse.com/1097158
https://bugzilla.suse.com/1097624
https://bugzilla.suse.com/1098592


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org