openSUSE-SU-2018:1908-1: important: Security update for rubygem-yard


openSUSE Security Update: Security update for rubygem-yard
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1908-1
Rating: important
References: #1070263
Cross-References: CVE-2017-17042
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for rubygem-yard fixes the following issues:

– CVE-2017-17042: The server in YARD did not block relative paths with an
initial ../ sequence, which allowed attackers to conduct directory
traversal attacks and read arbitrary files (bsc#1070263).

This update was imported from the SUSE:SLE-12-SP1:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-707=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

ruby2.1-rubygem-yard-0.8.7.3-8.3.1
ruby2.1-rubygem-yard-doc-0.8.7.3-8.3.1
ruby2.1-rubygem-yard-testsuite-0.8.7.3-8.3.1
ruby2.2-rubygem-yard-0.8.7.3-8.3.1
ruby2.2-rubygem-yard-doc-0.8.7.3-8.3.1
ruby2.2-rubygem-yard-testsuite-0.8.7.3-8.3.1
ruby2.3-rubygem-yard-0.8.7.3-8.3.1
ruby2.3-rubygem-yard-doc-0.8.7.3-8.3.1
ruby2.3-rubygem-yard-testsuite-0.8.7.3-8.3.1
ruby2.4-rubygem-yard-0.8.7.3-8.3.1
ruby2.4-rubygem-yard-doc-0.8.7.3-8.3.1
ruby2.4-rubygem-yard-testsuite-0.8.7.3-8.3.1

References:

https://www.suse.com/security/cve/CVE-2017-17042.html
https://bugzilla.suse.com/1070263


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org