openSUSE-SU-2018:1909-1: moderate: Security update for ghostscript


openSUSE Security Update: Security update for ghostscript
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:1909-1
Rating: moderate
References: #1090099
Cross-References: CVE-2018-10194
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for ghostscript fixes the following issues:

– CVE-2018-10194: The set_text_distance function did not prevent overflows
in text-positioning calculation, which allowed remote attackers to cause
a denial
of service (application crash) or possibly have unspecified other impact
via a crafted PDF document (bsc#1090099).

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-706=1

Package List:

– openSUSE Leap 15.0 (i586 x86_64):

ghostscript-9.23-lp150.2.3.1
ghostscript-debuginfo-9.23-lp150.2.3.1
ghostscript-debugsource-9.23-lp150.2.3.1
ghostscript-devel-9.23-lp150.2.3.1
ghostscript-mini-9.23-lp150.2.3.1
ghostscript-mini-debuginfo-9.23-lp150.2.3.1
ghostscript-mini-debugsource-9.23-lp150.2.3.1
ghostscript-mini-devel-9.23-lp150.2.3.1
ghostscript-x11-9.23-lp150.2.3.1
ghostscript-x11-debuginfo-9.23-lp150.2.3.1

References:

https://www.suse.com/security/cve/CVE-2018-10194.html
https://bugzilla.suse.com/1090099


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org