[USN-3703-1] Archive Zip


–===============4377513278169648270==
Content-Type: multipart/signed; micalg=”pgp-sha256″;
protocol=”application/pgp-signature”; boundary=”=-84Apl+ZKM355G1cCxkE+”

–=-84Apl+ZKM355G1cCxkE+
Content-Type: text/plain; charset=”UTF-8″
Content-Transfer-Encoding: quoted-printable

=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
Ubuntu Security Notice USN-3703-1
July 04, 2018

libarchive-zip-perl vulnerability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 18.04 LTS
– Ubuntu 17.10
– Ubuntu 16.04 LTS
– Ubuntu 14.04 LTS

Summary:

Archive Zip module could be made to expose sensitive information
if it received a specially crafted input.

Software Description:
– libarchive-zip-perl: Perl module for manipulation of ZIP archives

Details:

It was discovered that the Archive Zip module incorrectly handled
certain inputs. An attacker could possibly use this to access sensitive
information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
=C2=A0 libarchive-zip-perl=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A01.60-1ubuntu0.1

Ubuntu 17.10:
=C2=A0 libarchive-zip-perl=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A01.59-1ubuntu0.1

Ubuntu 16.04 LTS:
=C2=A0 libarchive-zip-perl=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A01.56-2ubuntu0.1

Ubuntu 14.04 LTS:
=C2=A0 libarchive-zip-perl=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A01.30-7ubuntu0.1

In general, a standard system update will make all the necessary
changes.

References:
=C2=A0 https://usn.ubuntu.com/usn/usn-3703-1
=C2=A0 CVE-2018-10860

Package Information:
=C2=A0 https://launchpad.net/ubuntu/+source/libarchive-zip-perl/1.60-1ubunt=
u0.1
=C2=A0 https://launchpad.net/ubuntu/+source/libarchive-zip-perl/1.59-1ubunt=
u0.1
=C2=A0 https://launchpad.net/ubuntu/+source/libarchive-zip-perl/1.56-2ubunt=
u0.1
=C2=A0 https://launchpad.net/ubuntu/+source/libarchive-zip-perl/1.30-7ubunt=
u0.1
–=-84Apl+ZKM355G1cCxkE+
Content-Type: application/pgp-signature; name=”signature.asc”
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

—–BEGIN PGP SIGNATURE—–
Version: GnuPG v2

iQIcBAABCAAGBQJbPPiZAAoJEEW851uECx9pPIEP/AvST4alkWLTyMYqZY49qwlv
TKHrtMj5OhukeGgflZnEbHb9hHlw0eqObybU5+TjoQkjAJ3/bTvblGKKDhTvVrc5
J0U6sK01d8GBNSScBsVVhxKehrZ8ksPiHkMTJgx9arS83G+8+mJbCFdo0W+EDLKF
cDXXZcB2IsGBBAZzMzuEmiyL9AFZJIrctcObxzBTsxGzGuBTYUmNgk3mqTDBCg91
DLhm9yTOHgwgdSsLAaQSbIfW4R9If0Nrw+4MRJqfcomDeZdSr2rWIlPioikwB77+
ZSKvBEBX3ybo9OcOciLbEDartqZzg04DdFY25FwNUJr7u11c333KARwCrEw9Uzu/
Xlpnu5ij0lfs6pRsSm8NHV/1PHEBo60lgV6JxVvWZfUgf2crUuVKeLj3sBPti/M1
AWHREB/DEgxbl1kmwbvuWINt0CBA4UtrYZ2EswPnOpQ4opA3lNPJTJQ06zSi27yb
sYHzaKunXnvhhs4MQJrGHFZenosnFONRi1//teQjm2REvJbopwX/pp/sSG8u5MU6
u6VNMGGLOBiGa2VBhEp8usQlLN1HxwI5Fytk3GrH+Qc64hV1LYSUTC781GeYPxcG
CVH4al9cz9rtxXSWLrexmbuB4yePcOhDkQiQdkF2ocQbTHUSuiPo1mwIK7fWeLq/
5qhgvm3d/JaEG+7hjaN5
=pD1R
—–END PGP SIGNATURE—–

–=-84Apl+ZKM355G1cCxkE+–

–===============4377513278169648270==
Content-Type: text/plain; charset=”utf-8″
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

–===============4377513278169648270==–