[USN-3704-1] devscripts vulnerability


–===============6848817193731471350==
Content-Type: multipart/signed; micalg=”pgp-sha256″;
protocol=”application/pgp-signature”; boundary=”=-oBpRB2OJTlo8X1zaFb2p”

–=-oBpRB2OJTlo8X1zaFb2p
Content-Type: text/plain; charset=”UTF-8″
Content-Transfer-Encoding: quoted-printable

=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
Ubuntu Security Notice USN-3704-1
July 05, 2018

devscripts vulnerability
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 18.04 LTS
– Ubuntu 17.10

Summary:

devscripts could be made to run arbitrary code if it received
a specially crafted YAML file.

Software Description:
– devscripts: scripts to make the life of a Debian Package maintainer
easier

Details:

It was discovered that devscripts incorrectly handled certain YAML
files. An attacker could possibly use this to execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.04 LTS:
=C2=A0 devscripts=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
2.17.12ubuntu1.1

Ubuntu 17.10:
=C2=A0 devscripts=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
2.17.9ubuntu0.1

In general, a standard system update will make all the necessary
changes.

References:
=C2=A0 https://usn.ubuntu.com/usn/usn-3704-1
=C2=A0 CVE-2018-13043

Package Information:
=C2=A0 https://launchpad.net/ubuntu/+source/devscripts/2.17.12ubuntu1.1
=C2=A0 https://launchpad.net/ubuntu/+source/devscripts/2.17.9ubuntu0.1
–=-oBpRB2OJTlo8X1zaFb2p
Content-Type: application/pgp-signature; name=”signature.asc”
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

—–BEGIN PGP SIGNATURE—–
Version: GnuPG v2

iQIcBAABCAAGBQJbPmHQAAoJEEW851uECx9pCvIQAJ8qnxlMlnLsFqCixxPNI+KU
3AMbMDb5HUFa/tPwpn2fVK71kiQblRnTwSJDzHWUnAdvDqwLWcRHSHehHSLMVATh
NdQq4Dt2ulfpu9JbHDVF6odPAj+xOPJLDzDmeCk2+uLtMyjifiNO3mMCaW7Xn8gc
99ESYgQOAJ4pCEWkvAPTXrO9RCEc78/SKrT5Bzk4dm0llUlCEzIEk4GdAxrpV8Ka
oVyP4GSnDRfmmiDyp/Smldwysy7ukWwUmwBXfjEIXHrDQHdR76ArzcqenMkXcQi0
PGQnezIFiSOSJj68SYKegi1Pzw3Ut7Gs5+MNQfLApPNrnr73jJPCz8n38ZlNGyXC
yAD0Xjq1KL9Yf4APzv4S3+PbZkiKyIS6ZTWlt8QKyHYlmVk0VQa/emBZsRmbVMl9
eZOC7KN/rs3D/IJ0+p+0VkIt/vfLDeAsWDiY25Ctmav0XFWFxy8sOYk1M0JITE1H
N7NFxPl/PCwNcLw4MsOZCbp5MokMTdbPGU79UsC4TTldqVwgHC03/iBvebWCmaFf
GvVWTK6K4FW54f+w9cxzs0kSNDtrHYwzUQaE7PHlU/yuKoVP8q/qVnxvcsyp93SB
YnzDNXeYE8xttyJ0muJGmFwe8IGKiLdfHKMAZWzA/+nTpvjSFgPWW4Zn3PqaIJAB
datq9n4DFWH/SadmCGbF
=hT+c
—–END PGP SIGNATURE—–

–=-oBpRB2OJTlo8X1zaFb2p–

–===============6848817193731471350==
Content-Type: text/plain; charset=”utf-8″
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK

–===============6848817193731471350==–