openSUSE-SU-2018:2215-1: moderate: Security update for rpm


openSUSE Security Update: Security update for rpm
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2215-1
Rating: moderate
References: #1094735 #1095148 #943457
Cross-References: CVE-2017-7500
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for rpm fixes the following issues:

This security vulnerability was fixed:

– CVE-2017-7500: Fixed symlink attacks during RPM installation (bsc#943457)

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-808=1

Package List:

– openSUSE Leap 15.0 (i586 x86_64):

python-rpm-debugsource-4.14.1-lp150.9.3.1
python2-rpm-4.14.1-lp150.9.3.1
python2-rpm-debuginfo-4.14.1-lp150.9.3.1
python3-rpm-4.14.1-lp150.9.3.1
python3-rpm-debuginfo-4.14.1-lp150.9.3.1
rpm-4.14.1-lp150.9.3.1
rpm-build-4.14.1-lp150.9.3.1
rpm-build-debuginfo-4.14.1-lp150.9.3.1
rpm-debuginfo-4.14.1-lp150.9.3.1
rpm-debugsource-4.14.1-lp150.9.3.1
rpm-devel-4.14.1-lp150.9.3.1

– openSUSE Leap 15.0 (x86_64):

rpm-32bit-4.14.1-lp150.9.3.1
rpm-32bit-debuginfo-4.14.1-lp150.9.3.1

References:

https://www.suse.com/security/cve/CVE-2017-7500.html
https://bugzilla.suse.com/1094735
https://bugzilla.suse.com/1095148
https://bugzilla.suse.com/943457


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org