openSUSE-SU-2018:2284-1: moderate: Security update for polkit


openSUSE Security Update: Security update for polkit
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2284-1
Rating: moderate
References: #1099031
Cross-References: CVE-2018-1116
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for polkit fixes the following issues:

Security issue fixed:

– CVE-2018-1116: Fix uid comparison lacking in
polkit_backend_interactive_authority_check_authorization (bsc#1099031).

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-848=1

Package List:

– openSUSE Leap 15.0 (i586 x86_64):

libpolkit0-0.114-lp150.2.3.1
libpolkit0-debuginfo-0.114-lp150.2.3.1
polkit-0.114-lp150.2.3.1
polkit-debuginfo-0.114-lp150.2.3.1
polkit-debugsource-0.114-lp150.2.3.1
polkit-devel-0.114-lp150.2.3.1
polkit-devel-debuginfo-0.114-lp150.2.3.1
typelib-1_0-Polkit-1_0-0.114-lp150.2.3.1

– openSUSE Leap 15.0 (x86_64):

libpolkit0-32bit-0.114-lp150.2.3.1
libpolkit0-32bit-debuginfo-0.114-lp150.2.3.1

– openSUSE Leap 15.0 (noarch):

polkit-doc-0.114-lp150.2.3.1

References:

https://www.suse.com/security/cve/CVE-2018-1116.html
https://bugzilla.suse.com/1099031


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org