openSUSE-SU-2018:2438-1: moderate: Security update for perl-Archive-Zip


openSUSE Security Update: Security update for perl-Archive-Zip
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2438-1
Rating: moderate
References: #1099497
Cross-References: CVE-2018-10860
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for perl-Archive-Zip fixes the following security issue:

– CVE-2018-10860: Prevent directory traversal caused by not properly
sanitizing paths while extracting zip files. An attacker able to provide
a specially crafted archive for processing could have used this flaw to
write or overwrite arbitrary files in the context of the perl
interpreter (bsc#1099497)

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-904=1

Package List:

– openSUSE Leap 15.0 (noarch):

perl-Archive-Zip-1.60-lp150.2.3.1

References:

https://www.suse.com/security/cve/CVE-2018-10860.html
https://bugzilla.suse.com/1099497


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org