openSUSE-SU-2018:2439-1: Security update for GraphicsMagick


openSUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2439-1
Rating: low
References: #1102007
Cross-References: CVE-2018-14435
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for GraphicsMagick fixes the following issues:

The following security issue was fixed:

– CVE-2018-14435: Fixed a memory leak in DecodeImage in coders/pcd.c
(boo#1102007)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-906=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

GraphicsMagick-1.3.25-96.2
GraphicsMagick-debuginfo-1.3.25-96.2
GraphicsMagick-debugsource-1.3.25-96.2
GraphicsMagick-devel-1.3.25-96.2
libGraphicsMagick++-Q16-12-1.3.25-96.2
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-96.2
libGraphicsMagick++-devel-1.3.25-96.2
libGraphicsMagick-Q16-3-1.3.25-96.2
libGraphicsMagick-Q16-3-debuginfo-1.3.25-96.2
libGraphicsMagick3-config-1.3.25-96.2
libGraphicsMagickWand-Q16-2-1.3.25-96.2
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-96.2
perl-GraphicsMagick-1.3.25-96.2
perl-GraphicsMagick-debuginfo-1.3.25-96.2

References:

https://www.suse.com/security/cve/CVE-2018-14435.html
https://bugzilla.suse.com/1102007


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org