openSUSE-SU-2018:2730-1: important: Security update for spice-gtk


openSUSE Security Update: Security update for spice-gtk
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2730-1
Rating: important
References: #1101295 #1101420 #1104448
Cross-References: CVE-2018-10873 CVE-2018-10893
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for spice-gtk fixes the following issues:

Security issues fixed:

– CVE-2018-10873: Fix potential heap corruption when demarshalling
(bsc#1104448)
– CVE-2018-10893: Avoid buffer overflow on image lz checks (bsc#1101295)

Other bugs fixed:

– Add setuid bit to spice-client-glib-usb-acl-helper (bsc#1101420)

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1015=1

Package List:

– openSUSE Leap 15.0 (x86_64):

libspice-client-glib-2_0-8-0.34-lp150.2.3.1
libspice-client-glib-2_0-8-debuginfo-0.34-lp150.2.3.1
libspice-client-glib-helper-0.34-lp150.2.3.1
libspice-client-glib-helper-debuginfo-0.34-lp150.2.3.1
libspice-client-gtk-3_0-5-0.34-lp150.2.3.1
libspice-client-gtk-3_0-5-debuginfo-0.34-lp150.2.3.1
libspice-controller0-0.34-lp150.2.3.1
libspice-controller0-debuginfo-0.34-lp150.2.3.1
spice-gtk-0.34-lp150.2.3.1
spice-gtk-debuginfo-0.34-lp150.2.3.1
spice-gtk-debugsource-0.34-lp150.2.3.1
spice-gtk-devel-0.34-lp150.2.3.1
typelib-1_0-SpiceClientGlib-2_0-0.34-lp150.2.3.1
typelib-1_0-SpiceClientGtk-3_0-0.34-lp150.2.3.1

– openSUSE Leap 15.0 (noarch):

spice-gtk-lang-0.34-lp150.2.3.1

References:

https://www.suse.com/security/cve/CVE-2018-10873.html
https://www.suse.com/security/cve/CVE-2018-10893.html
https://bugzilla.suse.com/1101295
https://bugzilla.suse.com/1101420
https://bugzilla.suse.com/1104448


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org