openSUSE-SU-2018:2733-1: moderate: Security update for okular


openSUSE Security Update: Security update for okular
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2733-1
Rating: moderate
References: #1107591
Cross-References: CVE-2018-1000801
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for okular fixes the following security issue:

– CVE-2018-1000801: Prevent directory traversal vulnerability in function
unpackDocumentArchive could have resulted in arbitrary file creation via
a specially crafted Okular archive (bsc#1107591).

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1006=1

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1006=1

Package List:

– openSUSE Leap 42.3 (x86_64):

okular-17.04.2-6.1
okular-debuginfo-17.04.2-6.1
okular-debugsource-17.04.2-6.1
okular-devel-17.04.2-6.1

– openSUSE Leap 42.3 (noarch):

okular-lang-17.04.2-6.1

– openSUSE Leap 15.0 (x86_64):

okular-17.12.3-lp150.3.3.1
okular-debuginfo-17.12.3-lp150.3.3.1
okular-debugsource-17.12.3-lp150.3.3.1
okular-devel-17.12.3-lp150.3.3.1

– openSUSE Leap 15.0 (noarch):

okular-lang-17.12.3-lp150.3.3.1

References:

https://www.suse.com/security/cve/CVE-2018-1000801.html
https://bugzilla.suse.com/1107591


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org