openSUSE-SU-2018:2736-1: moderate: Security update for curl


openSUSE Security Update: Security update for curl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2736-1
Rating: moderate
References: #1089533 #1106019
Cross-References: CVE-2018-14618
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for curl fixes the following issues:

This security issue was fixed:

– CVE-2018-14618: Prevent integer overflow in the NTLM authentication code
(bsc#1106019)

This non-security issue was fixed:

– Fixed erroneous debug message when paired with OpenSSL (bsc#1089533)

This update was imported from the SUSE:SLE-12:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1008=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

curl-7.37.0-39.1
curl-debuginfo-7.37.0-39.1
curl-debugsource-7.37.0-39.1
libcurl-devel-7.37.0-39.1
libcurl4-7.37.0-39.1
libcurl4-debuginfo-7.37.0-39.1

– openSUSE Leap 42.3 (x86_64):

libcurl-devel-32bit-7.37.0-39.1
libcurl4-32bit-7.37.0-39.1
libcurl4-debuginfo-32bit-7.37.0-39.1

References:

https://www.suse.com/security/cve/CVE-2018-14618.html
https://bugzilla.suse.com/1089533
https://bugzilla.suse.com/1106019


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org