openSUSE-SU-2018:2941-1: moderate: Security update for gd


openSUSE Security Update: Security update for gd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:2941-1
Rating: moderate
References: #1105434
Cross-References: CVE-2018-1000222
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gd fixes the following issues:

Security issue fixed:

– CVE-2018-1000222: Fixed a double free vulnerability in gdImageBmpPtr()
that could result in remote code execution. This could have been
exploited via a specially crafted JPEG image files. (bsc#1105434)

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1079=1

Package List:

– openSUSE Leap 15.0 (i586 x86_64):

gd-2.2.5-lp150.3.3.1
gd-debuginfo-2.2.5-lp150.3.3.1
gd-debugsource-2.2.5-lp150.3.3.1
gd-devel-2.2.5-lp150.3.3.1
libgd3-2.2.5-lp150.3.3.1
libgd3-debuginfo-2.2.5-lp150.3.3.1

– openSUSE Leap 15.0 (x86_64):

libgd3-32bit-2.2.5-lp150.3.3.1
libgd3-32bit-debuginfo-2.2.5-lp150.3.3.1

References:

https://www.suse.com/security/cve/CVE-2018-1000222.html
https://bugzilla.suse.com/1105434


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org