openSUSE-SU-2018:3109-1: important: Security update for git


openSUSE Security Update: Security update for git
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3109-1
Rating: important
References: #1110949
Cross-References: CVE-2018-17456
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for git fixes the following issues:

– CVE-2018-17456: Git allowed remote code execution during processing of a
recursive “git clone” of a superproject if a .gitmodules file has a URL
field beginning with a ‘-‘ character. (boo#1110949).

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1147=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

git-2.13.7-16.1
git-arch-2.13.7-16.1
git-core-2.13.7-16.1
git-core-debuginfo-2.13.7-16.1
git-credential-gnome-keyring-2.13.7-16.1
git-credential-gnome-keyring-debuginfo-2.13.7-16.1
git-cvs-2.13.7-16.1
git-daemon-2.13.7-16.1
git-daemon-debuginfo-2.13.7-16.1
git-debugsource-2.13.7-16.1
git-email-2.13.7-16.1
git-gui-2.13.7-16.1
git-svn-2.13.7-16.1
git-svn-debuginfo-2.13.7-16.1
git-web-2.13.7-16.1
gitk-2.13.7-16.1

– openSUSE Leap 42.3 (noarch):

git-doc-2.13.7-16.1

References:

https://www.suse.com/security/cve/CVE-2018-17456.html
https://bugzilla.suse.com/1110949


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org