openSUSE-SU-2018:3384-1: moderate: Security update for apache-pdfbox


openSUSE Security Update: Security update for apache-pdfbox
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:3384-1
Rating: moderate
References: #1099721 #1111009
Cross-References: CVE-2018-11797 CVE-2018-8036
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for apache-pdfbox fixes the following security issue:

– CVE-2018-8036: A crafted file could have triggered an infinite loop
which lead to DoS (bsc#1099721).
– CVE-2018-11797: A carefully crafted PDF file can trigger an extremely
long running computation when parsing the page tree. (bsc#1111009):

This update was imported from the SUSE:SLE-12-SP3:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1245=1

Package List:

– openSUSE Leap 42.3 (noarch):

apache-pdfbox-1.8.12-4.3.1
apache-pdfbox-javadoc-1.8.12-4.3.1

References:

https://www.suse.com/security/cve/CVE-2018-11797.html
https://www.suse.com/security/cve/CVE-2018-8036.html
https://bugzilla.suse.com/1099721
https://bugzilla.suse.com/1111009


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org