[USN-3815-1] gettext vulnerability

protocol=”application/pgp-signature”; boundary=”=-dQPpayBNqhFt7S1/fvMO”

–=-dQPpayBNqhFt7S1/fvMO

Content-Transfer-Encoding: quoted-printable

=
=

Ubuntu Security Notice USN-3815-1
November 12, 2018

gettext vulnerability
=
=

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 18.10
– Ubuntu 18.04 LTS
– Ubuntu 16.04 LTS
– Ubuntu 14.04 LTS

Summary:

gettext could be made to execute arbitrary code if it received
a specially crafted message.

Software Description:
– gettext: GNU Internationalization utilities

Details:

It was discovered that gettext incorrectly handled certain messages.
An attacker could possibly use this issue to execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.10:
=C2=A0 gettext=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A00.19.8.1-8ubuntu0.1

Ubuntu 18.04 LTS:
=C2=A0 gettext=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A00.19.8.1-6ubuntu0.1

Ubuntu 16.04 LTS:
=C2=A0 gettext=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A00.19.7-2ubuntu3.1

Ubuntu 14.04 LTS:
=C2=A0 gettext=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A00.18.3.1-1ubuntu3.1

In general, a standard system update will make all the necessary
changes.

References:
=C2=A0 https://usn.ubuntu.com/usn/usn-3815-1
=C2=A0 CVE-2018-18751

Package Information:
=C2=A0 https://launchpad.net/ubuntu/+source/gettext/0.19.8.1-8ubuntu0.1
=C2=A0 https://launchpad.net/ubuntu/+source/gettext/0.19.8.1-6ubuntu0.1
=C2=A0 https://launchpad.net/ubuntu/+source/gettext/0.19.7-2ubuntu3.1
=C2=A0 https://launchpad.net/ubuntu/+source/gettext/0.18.3.1-1ubuntu3.1
–=-dQPpayBNqhFt7S1/fvMO

Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

—–BEGIN PGP SIGNATURE—–
Version: GnuPG v2

iQIcBAABCAAGBQJb6XdJAAoJEEW851uECx9pwdAP/1qdjMdksKg+WUP7JiiO4Iql
O4s6AkJEJPoT75w0WSRMpOH9WnrWSrp/1c12WhCJUbLyXA0NYG1X06uUD4ZnSAG1
4PVOcupxi9Ts48Mj4g7K+VUxcn1+eG3TOYQ/euR6IKzjoOltSWlpIUht/537mSiR
VVqG8gtpLx9ohDX5LvzlNB0bWSiIwfbSSjrNdhmeA4MgwZnN65qGJlhGYRK2Pyn1
m/sZcf9StBtuudsMxDYmcOlEAcraBiV8pNVtg/8qyxMGCR+FOCIkUdko1aVrCQDc
NLhKrqggud1isOXBAS5QCUNo64/6uj/W8MXBjoAyDnpDHoI2+4TVgdUb6stsnofK
78bAJGmdhHRatYTGgy4rp/s/Xfxwg5imYx5qYYafRhJGWkm3JBL+DCdfvUyEuohO
A/Ly09BIaEGvZkcoxYNtTYHZzkLKyjRkmlhUtUEU3qX5WWLV9W2Rmk3eny72ouNH
zPN2DcnNVy6HjeBNqFK62p/3o6HNQVhO1NtP3eY6viwliS4kHSDTN/PJXQVFfgxi
B86rtWr2cwjbTKOjm7SxZdWxBdlrmrVQhYkaXMqzHnNMsvDDMxpZtSAnSfTJAlrw
SfxecibKWQM5rIICjUhjDFF+j7LoeADHeshSECgOZglfiTLq6HGZTswM7kwElgFb
s2T2C/dFa4NL+M69Spj0
=Bmvq
—–END PGP SIGNATURE—–

–=-dQPpayBNqhFt7S1/fvMO–

MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK