[USN-3816-3] systemd regression


This is an OpenPGP/MIME signed message (RFC 4880 and 3156)

protocol=”application/pgp-signature”;
boundary=”FzgwiF9eWWRunIcitwuMPcMkCi8nW5Wnn”

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
–FzgwiF9eWWRunIcitwuMPcMkCi8nW5Wnn

protected-headers=”v1″
From: Chris Coulson
Reply-To: Ubuntu Security
To: ubuntu-security-announce@lists.ubuntu.com
Message-ID:
Subject: [USN-3816-3] systemd regression

–JWLi2gIUrzIfLy6E4DbyCke6eJfPJme9Z

Content-Transfer-Encoding: quoted-printable
Content-Language: en-US

=
=

Ubuntu Security Notice USN-3816-3
November 27, 2018

systemd regression
=
=

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 16.04 LTS

Summary:

USN-3816-1 caused a regression in systemd-tmpfiles.

Software Description:
– systemd: system and service manager

Details:

USN-3816-1 fixed vulnerabilities in systemd. The fix for CVE-2018-6954
caused a regression in systemd-tmpfiles when running Ubuntu inside a
container on some older kernels. This issue only affected Ubuntu 16.04
LTS. In order to continue to support this configuration, the fixes for
CVE-2018-6954 have been reverted.

We apologize for the inconvenience.

Original advisory details:

=C2=A0Jann Horn discovered that unit_deserialize incorrectly handled stat=
us
messages
=C2=A0above a certain length. A local attacker could potentially exploit =
this via
=C2=A0NotifyAccess to inject arbitrary state across re-execution and obta=
in root
=C2=A0privileges. (CVE-2018-15686)
=C2=A0
=C2=A0Jann Horn discovered a race condition in chown_one(). A local attac=
ker
=C2=A0could potentially exploit this by setting arbitrary permissions on =
certain
=C2=A0files to obtain root privileges. This issue only affected Ubuntu 18=
=2E04 LTS
=C2=A0and Ubuntu 18.10. (CVE-2018-15687)
=C2=A0
=C2=A0It was discovered that systemd-tmpfiles mishandled symlinks in
=C2=A0non-terminal path components. A local attacker could potentially ex=
ploit
=C2=A0this by gaining ownership of certain files to obtain root privilege=
s. This
=C2=A0issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-201=
8-6954)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS:
=C2=A0 systemd=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 229-4ubuntu21.10

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
=C2=A0 https://usn.ubuntu.com/usn/usn-3816-3
=C2=A0 https://usn.ubuntu.com/usn/usn-3816-1
=C2=A0 https://launchpad.net/bugs/1804847

Package Information:
=C2=A0 https://launchpad.net/ubuntu/+source/systemd/229-4ubuntu21.10

–JWLi2gIUrzIfLy6E4DbyCke6eJfPJme9Z–

–FzgwiF9eWWRunIcitwuMPcMkCi8nW5Wnn

Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename=”signature.asc”

—–BEGIN PGP SIGNATURE—–

iQEzBAEBCgAdFiEERN//5MGgCOgyKeIFYR+97NWUbg8FAlv9oG8ACgkQYR+97NWU
bg/cewf/Y+P22INAYdfu6YcEa9rwkEPFvFgTiGbihLYH+SRW6kAzpz+SBHxMcRiK
/B4Le8EQTso3NFc7uj2pywehPqpEj9kWc7SoQQq4dvYCMolYD/SH0XunmJNzgK3t
kg2s+jIohLwK3UohU4Cfbr2xQyC/jvy5uJh0Evv7bKKGfLCKnAtsbicE/D02pHAF
BCIilfCETvDdkUr3E8IpntxfEMZ4uBq9i/t5lUPBtLXiEzgWu/TRzX/FcYtjfCSF
h1qpQpWca0dvY8SmOQ7GfHkxsizADyx84LGPY2E7OeyKv6Yq4GPXrtcO9PVAq9TF
FvdruiCVy9bI4dgGH5h4Y+BxtwjZGg==
=hxEq
—–END PGP SIGNATURE—–

–FzgwiF9eWWRunIcitwuMPcMkCi8nW5Wnn–

MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK