openSUSE-SU-2018:4005-1: moderate: Security update for glib2


openSUSE Security Update: Security update for glib2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4005-1
Rating: moderate
References: #1107116 #1107121 #1111499
Cross-References: CVE-2018-16428 CVE-2018-16429
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for glib2 fixes the following issues:

Security issues fixed:

– CVE-2018-16428: Do not do a NULL pointer dereference (crash). Avoid
that, at the cost of introducing a new translatable error message
(bsc#1107121).
– CVE-2018-16429: Fixed out-of-bounds read vulnerability
ing_markup_parse_context_parse() (bsc#1107116).

Non-security issue fixed:

– various GVariant parsing issues have been resolved (bsc#1111499)

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1485=1

Package List:

– openSUSE Leap 15.0 (i586 x86_64):

glib2-debugsource-2.54.3-lp150.3.3.1
glib2-devel-2.54.3-lp150.3.3.1
glib2-devel-debuginfo-2.54.3-lp150.3.3.1
glib2-devel-static-2.54.3-lp150.3.3.1
glib2-tools-2.54.3-lp150.3.3.1
glib2-tools-debuginfo-2.54.3-lp150.3.3.1
libgio-2_0-0-2.54.3-lp150.3.3.1
libgio-2_0-0-debuginfo-2.54.3-lp150.3.3.1
libgio-fam-2.54.3-lp150.3.3.1
libgio-fam-debuginfo-2.54.3-lp150.3.3.1
libglib-2_0-0-2.54.3-lp150.3.3.1
libglib-2_0-0-debuginfo-2.54.3-lp150.3.3.1
libgmodule-2_0-0-2.54.3-lp150.3.3.1
libgmodule-2_0-0-debuginfo-2.54.3-lp150.3.3.1
libgobject-2_0-0-2.54.3-lp150.3.3.1
libgobject-2_0-0-debuginfo-2.54.3-lp150.3.3.1
libgthread-2_0-0-2.54.3-lp150.3.3.1
libgthread-2_0-0-debuginfo-2.54.3-lp150.3.3.1

– openSUSE Leap 15.0 (x86_64):

glib2-devel-32bit-2.54.3-lp150.3.3.1
glib2-devel-32bit-debuginfo-2.54.3-lp150.3.3.1
glib2-tools-32bit-2.54.3-lp150.3.3.1
glib2-tools-32bit-debuginfo-2.54.3-lp150.3.3.1
libgio-2_0-0-32bit-2.54.3-lp150.3.3.1
libgio-2_0-0-32bit-debuginfo-2.54.3-lp150.3.3.1
libgio-fam-32bit-2.54.3-lp150.3.3.1
libgio-fam-32bit-debuginfo-2.54.3-lp150.3.3.1
libglib-2_0-0-32bit-2.54.3-lp150.3.3.1
libglib-2_0-0-32bit-debuginfo-2.54.3-lp150.3.3.1
libgmodule-2_0-0-32bit-2.54.3-lp150.3.3.1
libgmodule-2_0-0-32bit-debuginfo-2.54.3-lp150.3.3.1
libgobject-2_0-0-32bit-2.54.3-lp150.3.3.1
libgobject-2_0-0-32bit-debuginfo-2.54.3-lp150.3.3.1
libgthread-2_0-0-32bit-2.54.3-lp150.3.3.1
libgthread-2_0-0-32bit-debuginfo-2.54.3-lp150.3.3.1

– openSUSE Leap 15.0 (noarch):

gio-branding-upstream-2.54.3-lp150.3.3.1
glib2-lang-2.54.3-lp150.3.3.1

References:

https://www.suse.com/security/cve/CVE-2018-16428.html
https://www.suse.com/security/cve/CVE-2018-16429.html
https://bugzilla.suse.com/1107116
https://bugzilla.suse.com/1107121
https://bugzilla.suse.com/1111499


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org