openSUSE-SU-2018:4055-1: important: Security update for ncurses


openSUSE Security Update: Security update for ncurses
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4055-1
Rating: important
References: #1103320 #1115929
Cross-References: CVE-2018-19211
Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for ncurses fixes the following issues:

Security issue fixed:

– CVE-2018-19211: Fixed denial of service issue that was triggered by a
NULL pointer dereference at function _nc_parse_entry (bsc#1115929).

Non-security issue fixed:

– Remove scree.xterm from terminfo data base as with this screen uses
fallback TERM=screen (bsc#1103320).

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1516=1

Package List:

– openSUSE Leap 15.0 (i586 x86_64):

libncurses5-6.1-lp150.4.3.1
libncurses5-debuginfo-6.1-lp150.4.3.1
libncurses6-6.1-lp150.4.3.1
libncurses6-debuginfo-6.1-lp150.4.3.1
ncurses-debugsource-6.1-lp150.4.3.1
ncurses-devel-6.1-lp150.4.3.1
ncurses-devel-debuginfo-6.1-lp150.4.3.1
ncurses-utils-6.1-lp150.4.3.1
ncurses-utils-debuginfo-6.1-lp150.4.3.1
ncurses5-devel-6.1-lp150.4.3.1
tack-6.1-lp150.4.3.1
tack-debuginfo-6.1-lp150.4.3.1
terminfo-6.1-lp150.4.3.1
terminfo-base-6.1-lp150.4.3.1
terminfo-iterm-6.1-lp150.4.3.1
terminfo-screen-6.1-lp150.4.3.1

– openSUSE Leap 15.0 (x86_64):

libncurses5-32bit-6.1-lp150.4.3.1
libncurses5-32bit-debuginfo-6.1-lp150.4.3.1
libncurses6-32bit-6.1-lp150.4.3.1
libncurses6-32bit-debuginfo-6.1-lp150.4.3.1
ncurses-devel-32bit-6.1-lp150.4.3.1
ncurses-devel-32bit-debuginfo-6.1-lp150.4.3.1
ncurses5-devel-32bit-6.1-lp150.4.3.1

References:

https://www.suse.com/security/cve/CVE-2018-19211.html
https://bugzilla.suse.com/1103320
https://bugzilla.suse.com/1115929


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org