openSUSE-SU-2018:4299-1: moderate: Security update for libraw


openSUSE Security Update: Security update for libraw
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4299-1
Rating: moderate
References: #1097973 #1097974 #1097975 #1118894
Cross-References: CVE-2018-5804 CVE-2018-5805 CVE-2018-5806
CVE-2018-5808 CVE-2018-5816
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This update for libraw fixes the following issues:

The following security vulnerabilities were addressed:

– CVE-2018-5804: Fixed a type confusion error within the identify function
that could trigger a division by zero, leading to a denial of service
(Dos). (boo#1097975)
– CVE-2018-5805: Fixed a boundary error within the quicktake_100_load_raw
function that could cause a stack-based buffer overflow and subsequently
trigger a crash. (boo#1097973)
– CVE-2018-5806: Fixed an error within the leaf_hdr_load_raw function that
could trigger a NULL pointer deference, leading to a denial of service
(DoS). (boo#1097974)
– CVE-2018-5808: Fixed an error within the find_green function that could
cause a stack-based buffer overflow and subsequently execute arbitrary
code. (boo#1118894)
– CVE-2018-5816: Fixed a type confusion error within the identify function
that could trigger a division by zero, leading to a denial of service
(DoS). (boo#1097975)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-1619=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

libraw-debugsource-0.17.1-26.1
libraw-devel-0.17.1-26.1
libraw-devel-static-0.17.1-26.1
libraw-tools-0.17.1-26.1
libraw-tools-debuginfo-0.17.1-26.1
libraw15-0.17.1-26.1
libraw15-debuginfo-0.17.1-26.1

References:

https://www.suse.com/security/cve/CVE-2018-5804.html
https://www.suse.com/security/cve/CVE-2018-5805.html
https://www.suse.com/security/cve/CVE-2018-5806.html
https://www.suse.com/security/cve/CVE-2018-5808.html
https://www.suse.com/security/cve/CVE-2018-5816.html
https://bugzilla.suse.com/1097973
https://bugzilla.suse.com/1097974
https://bugzilla.suse.com/1097975
https://bugzilla.suse.com/1118894


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org