openSUSE-SU-2018:4307-1: moderate: Security update for wireshark


openSUSE Security Update: Security update for wireshark
______________________________________________________________________________

Announcement ID: openSUSE-SU-2018:4307-1
Rating: moderate
References: #1117740
Cross-References: CVE-2018-19622 CVE-2018-19623 CVE-2018-19624
CVE-2018-19625 CVE-2018-19626 CVE-2018-19627

Affected Products:
openSUSE Leap 15.0
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available.

Description:

This update for wireshark fixes the following issues:

Update to Wireshark 2.4.11 (bsc#1117740).

Security issues fixed:

– CVE-2018-19625: The Wireshark dissection engine could crash
(wnpa-sec-2018-51)
– CVE-2018-19626: The DCOM dissector could crash (wnpa-sec-2018-52)
– CVE-2018-19623: The LBMPDM dissector could crash (wnpa-sec-2018-53)
– CVE-2018-19622: The MMSE dissector could go into an infinite loop
(wnpa-sec-2018-54)
– CVE-2018-19627: The IxVeriWave file parser could crash (wnpa-sec-2018-55)
– CVE-2018-19624: The PVFS dissector could crash (wnpa-sec-2018-56)

Further bug fixes and updated protocol support as listed in:

– https://www.wireshark.org/docs/relnotes/wireshark-2.4.11.html

This update was imported from the SUSE:SLE-15:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2018-1620=1

Package List:

– openSUSE Leap 15.0 (i586 x86_64):

libwireshark9-2.4.11-lp150.2.16.1
libwireshark9-debuginfo-2.4.11-lp150.2.16.1
libwiretap7-2.4.11-lp150.2.16.1
libwiretap7-debuginfo-2.4.11-lp150.2.16.1
libwscodecs1-2.4.11-lp150.2.16.1
libwscodecs1-debuginfo-2.4.11-lp150.2.16.1
libwsutil8-2.4.11-lp150.2.16.1
libwsutil8-debuginfo-2.4.11-lp150.2.16.1
wireshark-2.4.11-lp150.2.16.1
wireshark-debuginfo-2.4.11-lp150.2.16.1
wireshark-debugsource-2.4.11-lp150.2.16.1
wireshark-devel-2.4.11-lp150.2.16.1
wireshark-ui-qt-2.4.11-lp150.2.16.1
wireshark-ui-qt-debuginfo-2.4.11-lp150.2.16.1

References:

https://www.suse.com/security/cve/CVE-2018-19622.html
https://www.suse.com/security/cve/CVE-2018-19623.html
https://www.suse.com/security/cve/CVE-2018-19624.html
https://www.suse.com/security/cve/CVE-2018-19625.html
https://www.suse.com/security/cve/CVE-2018-19626.html
https://www.suse.com/security/cve/CVE-2018-19627.html
https://bugzilla.suse.com/1117740


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org