[USN-3837-2] poppler regression

protocol=”application/pgp-signature”; boundary=”=-E+VQjApnoxrwokiKWDlx”

–=-E+VQjApnoxrwokiKWDlx

Content-Transfer-Encoding: quoted-printable

=
=

Ubuntu Security Notice USN-3837-2
December 11, 2018

poppler regression
=
=

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 18.10
– Ubuntu 18.04 LTS
– Ubuntu 16.04 LTS
– Ubuntu 14.04 LTS

Summary:

USN-3837-1 introduced a regression in poppler.

Software Description:
– poppler: PDF rendering library

Details:

USN-3837-1 fixed vulnerabilities in poppler. A regression was reported
regarding the previous update. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

=C2=A0It was discovered that poppler incorrectly handled certain PDF files.
=C2=A0An attacker could possibly use this issue to cause a denial of
=C2=A0service. (CVE-2018-16646)

=C2=A0It was discovered that poppler incorrectly handled certain PDF files.
=C2=A0An attacker could possibly use this issue to cause a denial of
=C2=A0service. This issue only affected Ubuntu 16.04 LTS.
=C2=A0(CVE-2018-19149)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 18.10:
=C2=A0 libpoppler79=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.68.0-0u=
buntu1.3
=C2=A0 poppler-utils=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.68.0-0ubuntu1=
.3

Ubuntu 18.04 LTS:
=C2=A0 libpoppler73=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.62.0-2u=
buntu2.5
=C2=A0 poppler-utils=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.62.0-2ubuntu2=
.5

Ubuntu 16.04 LTS:
=C2=A0 libpoppler58=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.41.0-0u=
buntu1.10
=C2=A0 poppler-utils=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.41.0-0ubuntu1=
.10

Ubuntu 14.04 LTS:
=C2=A0 libpoppler44=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.24.5-2u=
buntu4.14
=C2=A0 poppler-utils=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A00.24.5-2ubuntu4=
.14

In general, a standard system update will make all the necessary
changes.

References:
=C2=A0 https://usn.ubuntu.com/usn/usn-3837-2
=C2=A0 https://usn.ubuntu.com/usn/usn-3837-1
=C2=A0 CVE-2018-16646, CVE-2018-19149

Package Information:
=C2=A0 https://launchpad.net/ubuntu/+source/poppler/0.68.0-0ubuntu1.3
=C2=A0 https://launchpad.net/ubuntu/+source/poppler/0.62.0-2ubuntu2.5
=C2=A0 https://launchpad.net/ubuntu/+source/poppler/0.41.0-0ubuntu1.10
=C2=A0 https://launchpad.net/ubuntu/+source/poppler/0.24.5-2ubuntu4.14
–=-E+VQjApnoxrwokiKWDlx

Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

—–BEGIN PGP SIGNATURE—–
Version: GnuPG v2

iQIcBAABCAAGBQJcD/Z7AAoJEEW851uECx9py/oP/jYwTOnVKMvVQA6Mk2CTb3qj
u1t5f+QqVl4qyJVNaG3eNkH1wJ3YCmAPb9DSTUPa5I5BH5feC7b+p98muUUIx+4f
gaboVmUO+p6Eq7V3f3AtD1YG0xHWB1I48IxqeSgf4+q67+JSlVRZxnzIuLa0i03b
WvKOocTdiGYK1EGUz+mdoHPPz2WX5UOYE2/56LYIgFZ4zI8uto5ttMS/c//CkRys
L3VBUDinRyAwmrN/mltPrnSoEpBGHWOs6RoaOZXpM1uAlqiyZ3soiBFJEu5Wdrd3
r0ypWI8idTB1loimwneTJI8ZxxuhkT+kIrAhnpQzjiQ8PzXVdmt70ykWq30BERHr
xd5rrqAT+XcOQ27vUmVPdBNPjXbaJ9qOrQbkWE3FvL/Hz6PWK45eETiXgBMxbsys
V526RM8lCa/V6oyF5Wn17abAGRFvLkC9DBRIg4f+qssE499GPFhOo13uOmcgPKOo
08/xwAtxgDhFzpoTP15XAPiIQxfo8rY2I+m/igVRnGA7LbUZTM6WZU5KZMGEn5Fv
ROB97Oj0lpU+LHwL1dLJJaYgDei4zbxxH17YwW3rCJkDIKLMqj5q2HDIhq0qrU48
FEVV38i/3aaqMFEWbJd1qFU2bzCr3jK6Qj2btJpMBDcjZCfKuQvRsdgJDL0XyLJP
nYC6/CF0Trc3Bd8uyQfJ
=GECU
—–END PGP SIGNATURE—–

–=-E+VQjApnoxrwokiKWDlx–

MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK