openSUSE-SU-2019:0003-1: moderate: Security update for GraphicsMagick


openSUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0003-1
Rating: moderate
References: #1119790 #1119822
Cross-References: CVE-2018-20184 CVE-2018-20189
Affected Products:
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for GraphicsMagick fixes the following issues:

Security vulnerabilities fixed:

– CVE-2018-20184: Fixed heap-based buffer overflow in the WriteTGAImage
function of tga.c (bsc#1119822)
– CVE-2018-20189: Fixed denial of service vulnerability in ReadDIBImage
function of coders/dib.c (bsc#1119790)

This update was imported from the openSUSE:Leap:15.0:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-3=1

Package List:

– openSUSE Backports SLE-15 (x86_64):

GraphicsMagick-1.3.29-bp150.2.12.1
GraphicsMagick-devel-1.3.29-bp150.2.12.1
libGraphicsMagick++-Q16-12-1.3.29-bp150.2.12.1
libGraphicsMagick++-devel-1.3.29-bp150.2.12.1
libGraphicsMagick-Q16-3-1.3.29-bp150.2.12.1
libGraphicsMagick3-config-1.3.29-bp150.2.12.1
libGraphicsMagickWand-Q16-2-1.3.29-bp150.2.12.1
perl-GraphicsMagick-1.3.29-bp150.2.12.1

References:

https://www.suse.com/security/cve/CVE-2018-20184.html
https://www.suse.com/security/cve/CVE-2018-20189.html
https://bugzilla.suse.com/1119790
https://bugzilla.suse.com/1119822


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org