openSUSE-SU-2019:0054-1: moderate: Security update for gitolite


openSUSE Security Update: Security update for gitolite
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0054-1
Rating: moderate
References: #1121570
Cross-References: CVE-2018-20683
Affected Products:
openSUSE Leap 42.3
openSUSE Leap 15.0
openSUSE Backports SLE-15
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gitolite fixes the following security issue:

– CVE-2018-20683: The rsync command line was not handled correctly, allow
malicious rsync options (boo#1121570)

The version update to 3.6.11 also contains a number of upstream bug fixes.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-54=1

– openSUSE Leap 15.0:

zypper in -t patch openSUSE-2019-54=1

– openSUSE Backports SLE-15:

zypper in -t patch openSUSE-2019-54=1

Package List:

– openSUSE Leap 42.3 (noarch):

gitolite-3.6.11-4.6.1

– openSUSE Leap 15.0 (noarch):

gitolite-3.6.11-lp150.2.6.1

– openSUSE Backports SLE-15 (noarch):

gitolite-3.6.11-bp150.3.6.1

References:

https://www.suse.com/security/cve/CVE-2018-20683.html
https://bugzilla.suse.com/1121570


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org