openSUSE-SU-2019:0061-1: Security update for libunwind


openSUSE Security Update: Security update for libunwind
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0061-1
Rating: low
References: #1122012 #936786
Cross-References: CVE-2015-3239
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for libunwind fixes one minor security issue and one bug.

The following security issue was fixed:

– CVE-2015-3239: off-by-one error that could be triggered when reading
untrusted binaries (boo#936786)

The following packaging bug was fixed:

– boo#1122012: The 32 bit were not generated on Leap 42.3

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-61=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

libunwind-1.1-15.3.1
libunwind-debuginfo-1.1-15.3.1
libunwind-debugsource-1.1-15.3.1
libunwind-devel-1.1-15.3.1

– openSUSE Leap 42.3 (x86_64):

libunwind-32bit-1.1-15.3.1
libunwind-debuginfo-32bit-1.1-15.3.1

References:

https://www.suse.com/security/cve/CVE-2015-3239.html
https://bugzilla.suse.com/1122012
https://bugzilla.suse.com/936786


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org