[USN-3860-2] libcaca vulnerabilities

protocol=”application/pgp-signature”; boundary=”=-mQgPXDGZbUJJOKsQtOFy”

–=-mQgPXDGZbUJJOKsQtOFy

Content-Transfer-Encoding: quoted-printable

=
=

Ubuntu Security Notice USN-3860-2
January 15, 2019

libcaca vulnerabilities
=
=

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 12.04 ESM

Summary:

Several security issues were fixed in libcaca.

Software Description:
– libcaca: text mode graphics utilities

Details:

USN-3860-1 fixed a vulnerability in libcaca. This update provides
the corresponding update for Ubuntu 12.04 ESM.

Original advisory details:

=C2=A0It was discovered that libcaca incorrectly handled certain images.
=C2=A0An attacker could possibly use this issue to cause a denial of
=C2=A0service. (CVE-2018-20544)

=C2=A0It was discovered that libcaca incorrectly handled certain images.
=C2=A0An attacker could possibly use this issue to execute arbitrary code.
=C2=A0(CVE-2018-20545, CVE-2018-20548, CVE-2018-20459)

=C2=A0It was discovered that libcaca incorrectly handled certain images.
=C2=A0An attacker could possibly use this issue to access sensitive
=C2=A0information. (CVE-2018-20546, CVE-2018-20547)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 12.04 ESM:
=C2=A0 caca-utils=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
0.99.beta17-2.1ubuntu2.1
=C2=A0 libcaca0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A00.99.beta17-2.1ubuntu2.1

In general, a standard system update will make all the necessary
changes.

References:
=C2=A0 https://usn.ubuntu.com/usn/usn-3860-2
=C2=A0 https://usn.ubuntu.com/usn/usn-3860-1
=C2=A0 CVE-2018-20544, CVE-2018-20545, CVE-2018-20546, CVE-2018-20547,
=C2=A0 CVE-2018-20548, CVE-2018-20549
–=-mQgPXDGZbUJJOKsQtOFy

Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

—–BEGIN PGP SIGNATURE—–
Version: GnuPG v2

iQIcBAABCAAGBQJcPiP+AAoJEEW851uECx9plH0P/RwpHL26j7SoDr6XRh2veD5x
W1yMOPOEykxxxuZwrHdcSNIlPjRNXGl7Y7wKE3yYQptSvpVOgDw7YgZA3mdfilRa
RwKq7MiWSo5l1cbxiZT9R+PKY4sJrp4h2O+zKEohTIEalkMo0lKozYZDjZRnyoMT
yyNlXGqrrvaJRj8UzXX+JWgPQZvndlS9vpMejZnlCuRGKCjVVh8z59RiE8xnkfhj
lN5ejdfzSdLbRkK0dajgy50ibaJUWO6GrU1cM9aa/yE4hQz1s7egUzJsCUVe0LfC
ZGssMxT6aKonZpkTxeU3LXhX89/u1fGp6tLvNxe1sW7ReZcclwCZKb4RFuUBWeac
4sUPABKanCnxXCzcjqn1VS3SXqJBXPvC2Eyp/JYctePkukKlmsOcxnGRPYN4T7Lq
QCAhefJw565yFm/O5dxQmrR4kTE6H9CqxdU3ENEHtkLYaNswSPA1OEldPwlJNCN3
5GVRznlbvmAW5SI2UjsUKM0E21oYYyQNPNrxKPYhrrvcrAjErcIxSBgA+MArLEcG
cVTayIqOdmPGSsIzLmo+mFab5uN6zsJwlCgjgrWsTuCN2MI7eqgw43nlFlMY/mYj
JzgmfsVz1IHhkKDflyJPj4UtAc9fNxLffKYatESOhH/UX8WhnskfuATZcdpLNooF
z7IwLwRiYl6omXd7Iegk
=z6Z0
—–END PGP SIGNATURE—–

–=-mQgPXDGZbUJJOKsQtOFy–

MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

LS0gCnVidW50dS1zZWN1cml0eS1hbm5vdW5jZSBtYWlsaW5nIGxpc3QKdWJ1bnR1LXNlY3VyaXR5
LWFubm91bmNlQGxpc3RzLnVidW50dS5jb20KTW9kaWZ5IHNldHRpbmdzIG9yIHVuc3Vic2NyaWJl
IGF0OiBodHRwczovL2xpc3RzLnVidW50dS5jb20vbWFpbG1hbi9saXN0aW5mby91YnVudHUtc2Vj
dXJpdHktYW5ub3VuY2UK