openSUSE-SU-2019:0131-1: moderate: Security update for pdns-recursor


openSUSE Security Update: Security update for pdns-recursor
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0131-1
Rating: moderate
References: #1121887 #1121889
Cross-References: CVE-2019-3806 CVE-2019-3807
Affected Products:
SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for pdns-recursor to version 4.1.10 fixes the following issues:

Security issues fixed:

– CVE-2019-3806: Fixed a case when Lua hooks are not called over TCP
(boo#1121887)
– CVE-2019-3807: Fixed an issue where DNSSEC validation was not performed
for AA=0 responses (boo#1121889)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– SUSE Package Hub for SUSE Linux Enterprise 12:

zypper in -t patch openSUSE-2019-131=1

Package List:

– SUSE Package Hub for SUSE Linux Enterprise 12 (aarch64 ppc64le s390x x86_64):

pdns-recursor-4.1.10-16.1

References:

https://www.suse.com/security/cve/CVE-2019-3806.html
https://www.suse.com/security/cve/CVE-2019-3807.html
https://bugzilla.suse.com/1121887
https://bugzilla.suse.com/1121889


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org