openSUSE-SU-2019:0194-1: important: Security update for phpMyAdmin


openSUSE Security Update: Security update for phpMyAdmin
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0194-1
Rating: important
References: #1123271 #1123272
Cross-References: CVE-2019-6798 CVE-2019-6799
Affected Products:
SUSE Package Hub for SUSE Linux Enterprise 12
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for phpMyAdmin to version 4.8.5 fixes the following issues:

Security issues fixed:

– CVE-2019-6799: Fixed an arbitrary file read vulnerability (boo#1123272)
– CVE-2019-6798: Fixed a SQL injection in the designer interface
(boo#1123271)

Other changes:

* Fix rxport to SQL format not available
* Fix QR code not shown when adding two-factor authentication to a user
account
* Fix issue with adding a new user in MySQL 8.0.11 and newer
* Fix frozen interface relating to Text_Plain_Sql plugin
* Fix missing table level operations tab

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– SUSE Package Hub for SUSE Linux Enterprise 12:

zypper in -t patch openSUSE-2019-194=1

Package List:

– SUSE Package Hub for SUSE Linux Enterprise 12 (noarch):

phpMyAdmin-4.8.5-35.1

References:

https://www.suse.com/security/cve/CVE-2019-6798.html
https://www.suse.com/security/cve/CVE-2019-6799.html
https://bugzilla.suse.com/1123271
https://bugzilla.suse.com/1123272


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org