openSUSE-SU-2019:0214-1: Security update for GraphicsMagick


openSUSE Security Update: Security update for GraphicsMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:0214-1
Rating: low
References: #1124366
Cross-References: CVE-2019-7397
Affected Products:
openSUSE Leap 42.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for GraphicsMagick fixes the following issues:

Security issue fixed:

– CVE-2019-7397: Fixed a Memory leak in WritePDFImage function in pdf.c
(bsc#1124366).

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or “zypper patch”.

Alternatively you can run the command listed for your product:

– openSUSE Leap 42.3:

zypper in -t patch openSUSE-2019-214=1

Package List:

– openSUSE Leap 42.3 (i586 x86_64):

GraphicsMagick-1.3.25-126.1
GraphicsMagick-debuginfo-1.3.25-126.1
GraphicsMagick-debugsource-1.3.25-126.1
GraphicsMagick-devel-1.3.25-126.1
libGraphicsMagick++-Q16-12-1.3.25-126.1
libGraphicsMagick++-Q16-12-debuginfo-1.3.25-126.1
libGraphicsMagick++-devel-1.3.25-126.1
libGraphicsMagick-Q16-3-1.3.25-126.1
libGraphicsMagick-Q16-3-debuginfo-1.3.25-126.1
libGraphicsMagick3-config-1.3.25-126.1
libGraphicsMagickWand-Q16-2-1.3.25-126.1
libGraphicsMagickWand-Q16-2-debuginfo-1.3.25-126.1
perl-GraphicsMagick-1.3.25-126.1
perl-GraphicsMagick-debuginfo-1.3.25-126.1

References:

https://www.suse.com/security/cve/CVE-2019-7397.html
https://bugzilla.suse.com/1124366


To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org